summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2020-06-21 17:47:46 +0200
committerAntoine Viallon2020-06-21 17:47:46 +0200
commite63d3c55ab8f1b91306d1d74c0c0021dd8c3169e (patch)
treeef7f38f3b3d823d59930520270b308097cef2034
parent59bad066328a7f5d072bcf3af2a7e2e819d0e165 (diff)
downloadaur-e63d3c55ab8f1b91306d1d74c0c0021dd8c3169e.tar.gz
Update to 14.0 and fix bugs
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9be27de22b5..937b2a3cccdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = codelite-bin
pkgdesc = A cross platform C/C++/PHP and Node.js IDE written in C++
- pkgver = 13.0
+ pkgver = 14.0
pkgrel = 1
url = http://www.codelite.org/
arch = x86_64
license = GPL
makedepends = tar
- makedepends = xz
+ makedepends = lz4
depends = wxgtk3
+ depends = wxgtk2
depends = webkit2gtk
depends = clang
depends = lldb
@@ -19,6 +20,7 @@ pkgbase = codelite-bin
depends = curl
depends = python2
depends = hunspell
+ depends = uchardet
optdepends = graphviz: callgraph visualization
optdepends = clang: compiler
optdepends = gcc: compiler
@@ -31,9 +33,9 @@ pkgbase = codelite-bin
conflicts = codelite-git
replaces = codelite
replaces = codelite-svn
- noextract = codelite-13.0-1-x86_64.pkg.tar.xz
- source = https://www.lesviallon.fr/download/packages/x86_64/codelite-13.0-1-x86_64.pkg.tar.xz
- md5sums = 9fa46209a6f90e8d96a0092b7406493a
+ noextract = codelite-14.0-1-x86_64.pkg.tar.lz4
+ source = https://mirror.lesviallon.fr/aviallon/x86_64/codelite-14.0-1-x86_64.pkg.tar.lz4
+ sha256sums = bfc2c5472ea5a45c169c93af2e2e3f17d9cf10483e620adaf0e9c66e1b3770a5
pkgname = codelite-bin
diff --git a/PKGBUILD b/PKGBUILD
index d1f2261dd134..70c2b84f777b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Zeph <zeph33@gmail.com>
# Maintainer: Antoine Viallon <antoine.viallon@gmail.com>
pkgname=codelite-bin
-pkgver=13.0
+pkgver=14.0
pkgrel=1
_pkgname=codelite
_pkgrel=1
@@ -10,7 +10,7 @@ pkgdesc="A cross platform C/C++/PHP and Node.js IDE written in C++"
arch=('x86_64')
url="http://www.codelite.org/"
license=('GPL')
-depends=('wxgtk3' 'webkit2gtk'
+depends=('wxgtk3' 'wxgtk2' 'webkit2gtk'
'clang' 'lldb'
'libedit'
'libssh'
@@ -19,10 +19,11 @@ depends=('wxgtk3' 'webkit2gtk'
'xterm' 'curl'
'python2'
'hunspell'
+ 'uchardet'
)
-makedepends=('tar' 'xz')
+makedepends=('tar' 'lz4')
optdepends=( 'graphviz: callgraph visualization'
- 'clang: compiler'
+ 'clang: compiler'
'gcc: compiler'
'gdb: debugger'
'valgrind: debugger'
@@ -30,19 +31,20 @@ optdepends=( 'graphviz: callgraph visualization'
'nodejs: for Node.js IDE'
)
+_ext="lz4"
+_decomp="lz4"
replaces=('codelite' 'codelite-svn')
conflicts=('codelite' 'codelite-git')
provides=('codelite')
-
-source=("https://www.lesviallon.fr/download/packages/${CARCH}/${_pkgname}-${pkgver}-${_pkgrel}-${CARCH}.pkg.tar.xz")
-sha1sum=('baa8291ad50b7827c373cca0396f666c')
-noextract=(${_pkgname}-${pkgver}-${_pkgrel}-${CARCH}.pkg.tar.xz)
+source=("https://mirror.lesviallon.fr/aviallon/x86_64/${_pkgname}-${pkgver}-${_pkgrel}-${CARCH}.pkg.tar.${_ext}")
+#source=("https://www.lesviallon.fr/download/packages/${CARCH}/${_pkgname}-${pkgver}-${_pkgrel}-${CARCH}.pkg.tar.xz")
+sha256sums=('bfc2c5472ea5a45c169c93af2e2e3f17d9cf10483e620adaf0e9c66e1b3770a5')
+noextract=(${_pkgname}-${pkgver}-${_pkgrel}-${CARCH}.pkg.tar.${_ext})
package() {
- tar xf "${srcdir}/${_pkgname}-${pkgver}-${_pkgrel}-${CARCH}.pkg.tar.xz" -C "${pkgdir}"
+ tar -I ${_decomp} -xvf "${srcdir}/${_pkgname}-${pkgver}-${_pkgrel}-${CARCH}.pkg.tar.${_ext}" -C "${pkgdir}"
rm -f "${pkgdir}/.BUILDINFO"
rm -f "${pkgdir}/.MTREE"
rm -f "${pkgdir}/.PKGINFO"
# find "${pkgdir}/usr/bin" -type d -exec chmod 755 '{}' \;
}
-md5sums=('9fa46209a6f90e8d96a0092b7406493a')