summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2016-09-28 17:30:04 -0400
committerjgmdev2016-09-28 17:30:04 -0400
commit2a006223bed6951c8dc5659cbb2afe194277ff7a (patch)
treee9a2a0b56e55617c2f2012defae4ca5cd9326535
parent53103fa9dce0e5a6ca8721bdd2b4e82097f363f2 (diff)
downloadaur-2a006223bed6951c8dc5659cbb2afe194277ff7a.tar.gz
Added some other dependencies as found on main codelite aur package.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 41 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcca2e74b6bd..ec511ab67ceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Sep 28 18:54:30 UTC 2016
+# Wed Sep 28 21:29:05 UTC 2016
pkgbase = codelite-git
pkgdesc = Open-source, cross platform IDE for the C/C++ programming languages
pkgver = 9.2.r165.ga04baef
@@ -11,21 +11,27 @@ pkgbase = codelite-git
license = GPL
makedepends = pkgconfig
makedepends = cmake
+ makedepends = clang
depends = wxgtk
- depends = curl
depends = webkitgtk2
+ depends = libedit
depends = libssh
+ depends = libmariadbclient
+ depends = ncurses
depends = xterm
+ depends = curl
depends = python2
- depends = libedit
- depends = ncurses
- depends = valgrind
+ depends = clang
+ depends = lldb
+ depends = hunspell
optdepends = graphviz: callgraph visualization
- optdepends = lldb: debugger used by the lldb plugin
+ optdepends = clang: compiler
+ optdepends = gcc: compiler
+ optdepends = gdb: debugger
+ optdepends = valgrind: debugger
provides = codelite
conflicts = codelite
conflicts = codelite-bin
- conflicts = codelite4-svn
noextract = wxgui.zip
source = git://github.com/eranif/codelite.git
source = http://repos.codelite.org/wxCrafterLibs/wxgui.zip
diff --git a/PKGBUILD b/PKGBUILD
index ef14f396ecd6..9f581fcf060a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,31 @@ pkgrel=1
pkgdesc="Open-source, cross platform IDE for the C/C++ programming languages"
arch=('i686' 'x86_64')
url="http://www.codelite.org/"
-install=codelite-git.install
license=('GPL')
-depends=('wxgtk' 'curl' 'webkitgtk2' 'libssh' 'xterm' 'python2' 'libedit' 'ncurses' 'valgrind')
-makedepends=('pkgconfig' 'cmake')
+install=codelite-git.install
+makedepends=('pkgconfig' 'cmake' 'clang')
+depends=(
+ 'wxgtk'
+ 'webkitgtk2'
+ 'libedit'
+ 'libssh'
+ 'libmariadbclient'
+ 'ncurses'
+ 'xterm'
+ 'curl'
+ 'python2'
+ 'clang'
+ 'lldb'
+ 'hunspell'
+)
optdepends=(
'graphviz: callgraph visualization'
- 'lldb: debugger used by the lldb plugin'
+ 'clang: compiler'
+ 'gcc: compiler'
+ 'gdb: debugger'
+ 'valgrind: debugger'
)
-conflicts=('codelite' 'codelite-bin' 'codelite4-svn')
+conflicts=('codelite' 'codelite-bin')
provides=('codelite')
source=(
git://github.com/eranif/codelite.git
@@ -43,7 +59,12 @@ build() {
cd "${srcdir}/${_gitname}/build"
CXXFLAGS="${CXXFLAGS} -fno-devirtualize"
- cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DENABLE_CLANG=1 -DCMAKE_INSTALL_LIBDIR=lib ..
+
+ cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release \
+ -DENABLE_CLANG=1 -DENABLE_LLDB=1 -DWITH_MYSQL=1 \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ ..
+
make
}
@@ -53,4 +74,4 @@ package() {
make -j1 DESTDIR="${pkgdir}" install
install -m 644 -D "${srcdir}/wxgui.zip" "${pkgdir}/usr/share/codelite/wxgui.zip"
install -m 644 -D "${srcdir}/${_gitname}/LICENSE" "${pkgdir}/usr/share/licenses/codelite/LICENSE"
-} \ No newline at end of file
+}