summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahor2023-03-13 10:47:20 +0330
committerMahor2023-03-13 10:47:20 +0330
commitca2bce648f511c897eea8e550b8680f73902eb6c (patch)
treea88e98ef1029741931064eed1da1a4a4cbf5dc94
parentda25b0a7715e866a0d140661617bee4297c975da (diff)
downloadaur-ca2bce648f511c897eea8e550b8680f73902eb6c.tar.gz
update build process
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD38
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cabc0f1c156e..a3791822e064 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = codelldb-git
pkgdesc = A native debugger extension for VSCode based on LLDB. Also known as vscode-lldb (NOT lldb-vscode)
- pkgver = v1.7.3.r1032.557451d
+ pkgver = v1.9.0.r1084.88d6925
pkgrel = 1
- url = https://github.com/vadimcn/vscode-lldb
+ url = https://github.com/vadimcn/codelldb
arch = x86_64
arch = arm7h
arch = aarch64
license = MIT
- makedepends = git
makedepends = cmake
makedepends = cargo
makedepends = npm
makedepends = python
+ makedepends = libc++
+ makedepends = git
depends = lldb
provides = codelldb
provides = vscode-lldb
options = !debug
options = strip
- source = git+https://github.com/vadimcn/vscode-lldb.git
+ source = git+https://github.com/vadimcn/codelldb.git
sha256sums = SKIP
pkgname = codelldb-git
diff --git a/PKGBUILD b/PKGBUILD
index ac7a49541ed2..25984d57850e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,21 @@
pkgname=codelldb-git
_pkgname="${pkgname%-git}"
-_reponame=vscode-lldb
-pkgver=v1.7.3.r1032.557451d
+pkgver=v1.9.0.r1084.88d6925
pkgrel=1
pkgdesc="A native debugger extension for VSCode based on LLDB. Also known as vscode-lldb (NOT lldb-vscode)"
-arch=("x86_64" "arm7h" "aarch64")
-url="https://github.com/vadimcn/$_reponame"
-license=("MIT")
-provides=("$_pkgname" "$_reponame")
+arch=(x86_64 arm7h aarch64)
+url=https://github.com/vadimcn/codelldb
+license=(MIT)
+provides=("$_pkgname" "vscode-lldb")
depends=(lldb)
-makedepends=(git cmake cargo npm python)
+makedepends=(cmake cargo npm python libc++ git)
options=(!debug strip) #Debug package is broken
source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "$_reponame"
+ cd "$_pkgname"
printf "%s.r%s.%s"\
"$(git describe --tags | cut -d"-" -f1)"\
"$(git rev-list --count HEAD)"\
@@ -30,26 +29,26 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CFLAGS="-mtune=generic -O2 -pipe -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security"
# Doesn't build with -fno-plt
- cd "$_reponame"
+ cd "$_pkgname"
cmake -B build -DLLDB_PACKAGE=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
- cmake --build build --target codelldb
+ cmake --build build --target adapter
}
package() {
local reset_shopt="$(shopt -p globstar)"
shopt -s globstar
- cd "$_reponame"
- local _lib_dir="$pkgdir/usr/lib/$_pkgname"
+ cd "$_pkgname"
+ local libdir="$pkgdir/usr/lib/$_pkgname"
- # <https://github.com/vadimcn/vscode-lldb/blob/v1.7.0/CMakeLists.txt#L173-L186>
- install -Dm644 -t "$_lib_dir" build/platform.ok
- install -Dm755 -t "$_lib_dir"/adapter build/adapter/{codelldb,*.so}
- install -Dm644 -t "$_lib_dir"/adapter build/adapter/*.py
- install -Dm644 -t "$_lib_dir"/formatters build/formatters/**/*.py
+ #https://github.com/vadimcn/codelldb/blob/v1.9.0/CMakeLists.txt#L187-L200
+ install -Dm644 -t "$libdir" build/platform.ok
+ install -Dm755 -t "$libdir"/adapter build/adapter/{codelldb,*.so}
+ install -Dm644 -t "$libdir"/adapter build/adapter/scripts/**/*.py
+ install -Dm644 -t "$libdir"/formatters build/formatters/**/*.py
- install -d "$_lib_dir"/lldb
- ln -s -t "$_lib_dir"/lldb /usr/{bin,lib}
+ install -d "$libdir"/lldb
+ ln -s -t "$libdir"/lldb /usr/{bin,lib}
install -d "$pkgdir"/usr/bin
ln -s -t "$pkgdir"/usr/bin /usr/lib/"$_pkgname"/adapter/codelldb
@@ -57,3 +56,4 @@ package() {
install -Dm644 -t "$pkgdir"/usr/share/licenses/"$_pkgname" LICENSE
eval "$reset_shopt"
}
+