summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLenni Hein2021-03-15 02:37:02 +0100
committerLenni Hein2021-03-15 02:37:02 +0100
commit56fc81062839b72f71504939966ac8cbf5a579f8 (patch)
treecc487e2a9b17e22634cd852676db34f5629d496d
downloadaur-codeonly-git.tar.gz
v1.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a64dd3767f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = codeonly-git
+ pkgdesc = Remove annoying comments from your code
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/LostInTheCloud/codeonly
+ arch = any
+ license = GPL-2.0
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ source = codeonly-git::git+https://github.com/LostInTheCloud/codeonly
+ sha256sums = SKIP
+
+pkgname = codeonly-git
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70b129a75eac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# PKGBUILD created by using cargo-aur-packer
+pkgname='codeonly-git'
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='Remove annoying comments from your code'
+arch=('any')
+url='https://github.com/LostInTheCloud/codeonly'
+license=('GPL-2.0')
+sha256sums=('SKIP')
+makedepends=('rust' 'cargo' 'git')
+source=('codeonly-git::git+https://github.com/LostInTheCloud/codeonly')
+
+pkgver() {
+ cd "$pkgname"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)" | tr '-' '.'
+}
+
+build() {
+ cd "$pkgname"
+ cargo build --release --all-features --target-dir=target
+}
+
+check() {
+ cd "$pkgname"
+ cargo test --release --target-dir=target
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm 755 target/release/codeonly -t "${pkgdir}/usr/bin"
+ # install -Dm 755 LICENSE "${pkgdir}/usr/share/licenses/codeonly"
+}
+