summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphorcys2022-10-16 14:55:51 +0200
committerphorcys2022-10-16 14:55:51 +0200
commit6b1498b966df36d30a3f53c5f688264918fca5c3 (patch)
tree5a561235167d9ccfe50ee05e850be780e9208d57
downloadaur-6b1498b966df36d30a3f53c5f688264918fca5c3.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d37b36e3e17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = coder-bin
+ pkgdesc = Remote development environments on your infrastructure provisioned with Terraform
+ pkgver = 0.9.10
+ pkgrel = 1
+ url = https://coder.com
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = AGPL3
+ source_x86_64 = https://github.com/coder/coder/releases/download/v0.9.10/coder_0.9.10_linux_amd64.tar.gz
+ sha256sums_x86_64 = 448b3b770f77e8e66807534d5ca077d7ac1d771fe872e5ecf9d8629a900c1c52
+ source_aarch64 = https://github.com/coder/coder/releases/download/v0.9.10/coder_0.9.10_linux_arm64.tar.gz
+ sha256sums_aarch64 = 6cdfbcb343ab91e21489e4237456d8875ce3ed67819fa4f14d6d5b972025723d
+ source_armv7h = https://github.com/coder/coder/releases/download/v0.9.10/coder_0.9.10_linux_armv7.tar.gz
+ sha256sums_armv7h = c5b6158ddd94c99bd4a9ba63e13ec760bf8bbb7d3062d7cc16d0b36c4fa307f9
+
+pkgname = coder-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bf8523288265
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+
+*.tar.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f89f6c98e318
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Phorcys <aur@phorcys.net>
+pkgname=coder-bin
+pkgver="0.9.10"
+pkgrel=1
+pkgdesc="Remote development environments on your infrastructure provisioned with Terraform"
+arch=("x86_64" "aarch64" "armv7h")
+url="https://coder.com"
+license=("AGPL3")
+
+source_x86_64=("https://github.com/coder/coder/releases/download/v${pkgver}/coder_${pkgver}_linux_amd64.tar.gz")
+sha256sums_x86_64=("448b3b770f77e8e66807534d5ca077d7ac1d771fe872e5ecf9d8629a900c1c52")
+
+source_aarch64=("https://github.com/coder/coder/releases/download/v${pkgver}/coder_${pkgver}_linux_arm64.tar.gz")
+sha256sums_aarch64=("6cdfbcb343ab91e21489e4237456d8875ce3ed67819fa4f14d6d5b972025723d")
+
+source_armv7h=("https://github.com/coder/coder/releases/download/v${pkgver}/coder_${pkgver}_linux_armv7.tar.gz")
+sha256sums_armv7h=("c5b6158ddd94c99bd4a9ba63e13ec760bf8bbb7d3062d7cc16d0b36c4fa307f9")
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 coder "${pkgdir}/usr/bin/coder"
+}