summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-12-27 01:25:48 +0800
committerChocobo12022-12-27 01:25:48 +0800
commit2fb4c4692240b3afbf6706ca80cee78c6a1d124a (patch)
tree26c4556bbdde5aa42bd54d35872a3ad2d30fd5bb
parentf4f3a5b5582706525222fef29463eac13fdfede5 (diff)
downloadaur-codespell-git.tar.gz
upgpkg: codespell-git 2.2.2.r160.g36c8c276-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2140eb11f6f1..ad91623c0322 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = codespell-git
pkgdesc = Tool for fixing common misspellings in text files
- pkgver = 1.14.0.r258.g3743efc1
+ pkgver = 2.2.2.r160.g36c8c276
pkgrel = 1
url = https://github.com/codespell-project/codespell
arch = any
@@ -8,12 +8,14 @@ pkgbase = codespell-git
checkdepends = python-pytest
makedepends = git
makedepends = help2man
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools-scm
+ makedepends = python-wheel
depends = python
- depends = python-setuptools
- provides = codespell
+ provides = codespell=2.2.2.r160.g36c8c276
conflicts = codespell
source = git+https://github.com/codespell-project/codespell.git
sha256sums = SKIP
pkgname = codespell-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e90f015a710d..8c0abd1a0d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=codespell-git
-pkgver=1.14.0.r258.g3743efc1
+pkgver=2.2.2.r160.g36c8c276
pkgrel=1
pkgdesc="Tool for fixing common misspellings in text files"
arch=('any')
url="https://github.com/codespell-project/codespell"
license=('GPL2')
-depends=('python' 'python-setuptools')
-makedepends=('git' 'help2man')
+depends=('python')
+makedepends=('git' 'help2man' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
checkdepends=('python-pytest')
-provides=('codespell')
+provides=("codespell=$pkgver")
conflicts=('codespell')
source=("git+https://github.com/codespell-project/codespell.git")
sha256sums=('SKIP')
@@ -25,14 +25,17 @@ pkgver() {
build() {
cd "codespell"
- python "setup.py" build
- make
+ python \
+ -m build \
+ --wheel \
+ --no-isolation
}
package() {
cd "codespell"
- python "setup.py" install \
- --optimize 1 \
- --root "$pkgdir"
+ python \
+ -m installer \
+ --destdir="$pkgdir" \
+ dist/*.whl
}