summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2016-10-23 20:47:29 +0200
committerLukáš Jirkovský2016-10-23 20:47:29 +0200
commit81925f5b277b6daec12b94396776dfabfe9bcab8 (patch)
treebf97e42e04aa7adb65bc8501275e2f368571a6f0
parentabcba91912511f927bedb2418bd9f38cc118ae74 (diff)
downloadaur-81925f5b277b6daec12b94396776dfabfe9bcab8.tar.gz
find working sources for codeviz. The build is broken, though
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--codeviz.install3
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1bd54af479e..7c9b3aa93034 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Sun Oct 23 18:47:29 UTC 2016
pkgbase = codeviz
pkgdesc = A call graph generation utility for C/C++
pkgver = 1.0.12
pkgrel = 1
- url = http://www.csn.ul.ie/~mel/projects/codeviz/
+ url = https://github.com/petersenna/codeviz
install = codeviz.install
arch = i686
arch = x86_64
@@ -11,9 +13,9 @@ pkgbase = codeviz
depends = graphviz
noextract = gcc-4.6.4.tar.gz
options = !buildflags
- source = http://www.csn.ul.ie/~mel/projects/codeviz/codeviz-1.0.12.tar.gz
+ source = https://github.com/petersenna/codeviz/archive/8e597959959c4e812742e9d68c1ea4c4db63a39d.zip
source = ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.6.4/gcc-4.6.4.tar.gz
- md5sums = 31bb56aeccc8eefb24f23073bf523c48
+ md5sums = 5538e066a1c18fd7d49bfe8a9df92e68
md5sums = a8f15fc233589924ccd8cc8140b0ca3c
pkgname = codeviz
diff --git a/PKGBUILD b/PKGBUILD
index 4c8c82952c58..b0fa4a416be3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=codeviz
pkgver=1.0.12
+_pkgver=8e597959959c4e812742e9d68c1ea4c4db63a39d
_gccver=4.6.4
pkgrel=1
pkgdesc="A call graph generation utility for C/C++"
arch=('i686' 'x86_64')
-url="http://www.csn.ul.ie/~mel/projects/codeviz/"
+url="https://github.com/petersenna/codeviz"
license=('GPL2')
depends=('perl' 'graphviz')
# unset the C(XX)FLAGS because they would break the compilation if they contained
# options not supported in $_gccver
options=('!buildflags')
-source=(http://www.csn.ul.ie/~mel/projects/codeviz/codeviz-$pkgver.tar.gz \
+source=("https://github.com/petersenna/codeviz/archive/$_pkgver.zip"
ftp://ftp.gnu.org/pub/gnu/gcc/gcc-$_gccver/gcc-${_gccver}.tar.gz)
noextract=(gcc-${_gccver}.tar.gz)
install=codeviz.install
-md5sums=('31bb56aeccc8eefb24f23073bf523c48'
+md5sums=('5538e066a1c18fd7d49bfe8a9df92e68'
'a8f15fc233589924ccd8cc8140b0ca3c')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$_pkgver"
# disable problematic flags, solution by ftschindler from gcc46
CPPFLAGS=${CPPFLAGS//-D_FORTIFY_SOURCE=?/}
@@ -42,7 +43,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$_pkgver"
make DESTDIR="$pkgdir" install
}
diff --git a/codeviz.install b/codeviz.install
index e701d1e4b800..3651ed1c195e 100644
--- a/codeviz.install
+++ b/codeviz.install
@@ -1,7 +1,8 @@
post_install() {
cat << EOT
Patched gcc is installed to /opt/gccgraph. To compile a project
- for use with CodeViz, genearlly the following will work
+ for use with CodeViz, it is necessary to use this version of
+ gcc for compilation, such as:
make CC=/opt/gccgraph/bin/gcc or g++