summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecialworld832016-02-14 16:14:51 +0100
committerspecialworld832016-02-14 16:14:51 +0100
commit3c2a56c357586a34080805f54a47e348ed1b733e (patch)
tree3a7d8903097f96d4fc9626606b779afd7a06394c
parent54f7a7cac5dea67e21aed96b93dff88c7d051109 (diff)
downloadaur-3c2a56c357586a34080805f54a47e348ed1b733e.tar.gz
Update to 3.0
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD13
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 086a3b038f0d..2cae57adaf9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,27 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 15:14:33 UTC 2016
pkgbase = codicefiscale
pkgdesc = The tax code in Italy is an alphanumeric code with a fixed length of 16 characters, inspired by the use of library, which is used to uniquely identify the tax and administrative citizens.
- pkgver = 2.2.1
+ pkgver = 3.0
pkgrel = 2
url = http://www.codelinsoft.it/sito/2013-11-17-17-56-34/codice-fiscale.html
arch = i686
arch = x86_64
license = LGPL
- depends = qt4
- source = http://www.codelinsoft.it/sito/download/categoria-linux/CodiceFiscale/codice-fiscale-source.raw
- md5sums = 5f1ddab88c84b972f9bca075cdaf6ebf
+ depends = qt5-base
+ depends = qt5-connectivity
+ depends = qt5-declarative
+ depends = qt5-graphicaleffects
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qt5-translations
+ depends = qt5-webkit
+ depends = qt5-websockets
+ depends = qt5-x11extras
+ depends = qt5-xmlpatterns
+ source = http://www.codelinsoft.it/sito/download/categoria-linux/CodiceFiscale/codicefiscale-3-0targz.raw
+ md5sums = f62d26470b128e28d03f1c61f514eef4
pkgname = codicefiscale
diff --git a/PKGBUILD b/PKGBUILD
index 85c505f03618..f1d30e8a50a5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Contributor: Calogero e Angelo ScarnĂ  <info@codelinsoft.it>
pkgname=codicefiscale
-pkgver=2.2.1
+pkgver=3.0
pkgrel=2
pkgdesc="The tax code in Italy is an alphanumeric code with a fixed length of 16 characters, inspired by the use of library, which is used to uniquely identify the tax and administrative citizens."
url="http://www.codelinsoft.it/sito/2013-11-17-17-56-34/codice-fiscale.html"
arch=('i686' 'x86_64')
-depends=('qt4')
+depends=('qt5-base' 'qt5-connectivity' 'qt5-declarative' 'qt5-graphicaleffects' 'qt5-multimedia' 'qt5-svg' 'qt5-tools' 'qt5-translations' 'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-xmlpatterns' )
license=(LGPL)
-source=(http://www.codelinsoft.it/sito/download/categoria-linux/CodiceFiscale/codice-fiscale-source.raw)
-md5sums=("5f1ddab88c84b972f9bca075cdaf6ebf")
+source=(http://www.codelinsoft.it/sito/download/categoria-linux/CodiceFiscale/codicefiscale-3-0targz.raw)
+md5sums=("f62d26470b128e28d03f1c61f514eef4")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-qmake-qt4
+cmake -DCMAKE_INSTALL_PREFIX=/opt -DWANT_QT5=ON
make -j5
}
@@ -23,8 +23,9 @@ cd "${srcdir}/${pkgname}-${pkgver}"
install -d "$pkgdir"/opt
install -dm 755 ${pkgdir}/opt/codicefiscale
cp -rv "${srcdir}/${pkgname}-${pkgver}/cod_fisc/codicefiscale" "${pkgdir}/opt/codicefiscale/"
-cp -rv "${srcdir}/${pkgname}-${pkgver}/cod_fisc/update" "${pkgdir}/opt/codicefiscale/"
+cp -rv "${srcdir}/${pkgname}-${pkgver}/update" "${pkgdir}/opt/codicefiscale/"
cp -rv "${srcdir}/${pkgname}-${pkgver}/cod_fisc/images/codicefisc.png" "${pkgdir}/opt/codicefiscale/"
+cp -rv "${srcdir}/${pkgname}-${pkgver}/cod_fisc/codicefiscale.db" "${pkgdir}/opt/codicefiscale/"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/cod_fisc/desktop/codicefiscale.desktop" "${pkgdir}/usr/share/applications/codicefiscale.desktop"