summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2020-11-22 18:41:40 +0100
committerVianney le Clément de Saint-Marcq2020-11-22 18:41:40 +0100
commita2fc1d55ed4d2eadfec973f5d6c2b9d344a72f86 (patch)
tree38cbca565049bb0be7c00544ec48d39028fcc3b3
parentc07cfaf381bb9b6313d5ab2b98c4aa0b163cb494 (diff)
downloadaur-a2fc1d55ed4d2eadfec973f5d6c2b9d344a72f86.tar.gz
Update to 1.6.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--codimd.service8
-rw-r--r--config.json8
-rw-r--r--environment1
5 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f3b5f52f54c..4c7bc62a6800 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = codimd-bin
pkgdesc = Realtime collaborative markdown notes
- pkgver = 1.5.0
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/codimd/server
arch = x86_64
@@ -14,10 +14,10 @@ pkgbase = codimd-bin
source = sysusers.conf
source = environment
source = config.json
- sha256sums = dcb7d3a23b8d3be3a5b1067dc71e0e25046962c8bcf4e90e808cd9005fb32241
+ sha256sums = f1d514be9079c82a915689d4b7b043ffe9bb939fb24189ab13acf50968db5bed
sha256sums = 25e696ca1202b9df1287e23f40ffa8b909a629f4b3916c572561d953e44e3b22
sha256sums = 523ccf9d8c1795bd70523f22b0268be3efdc42a3e8bed7008285bc3b894e53c2
- sha256sums = befaec00c6bfd3e6472659ae52639cd94ddd8d10edb5c7d0301ede6d9a817917
+ sha256sums = 306724434e97ff7d9ae557cda0b905f6946aab19d5621bd47195599edbd098b5
pkgname = codimd-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0cd390529437..cd6651368b94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Vianney le Clément de Saint-Marcq <code AT quartic·eu>
pkgname=codimd-bin
-pkgver=1.5.0
+pkgver=1.6.0
pkgrel=1
pkgdesc="Realtime collaborative markdown notes"
arch=('x86_64')
@@ -14,16 +14,16 @@ source=('codimd.service'
'sysusers.conf'
'environment'
'config.json')
-sha256sums=('dcb7d3a23b8d3be3a5b1067dc71e0e25046962c8bcf4e90e808cd9005fb32241'
+sha256sums=('f1d514be9079c82a915689d4b7b043ffe9bb939fb24189ab13acf50968db5bed'
'25e696ca1202b9df1287e23f40ffa8b909a629f4b3916c572561d953e44e3b22'
'523ccf9d8c1795bd70523f22b0268be3efdc42a3e8bed7008285bc3b894e53c2'
- 'befaec00c6bfd3e6472659ae52639cd94ddd8d10edb5c7d0301ede6d9a817917')
+ '306724434e97ff7d9ae557cda0b905f6946aab19d5621bd47195599edbd098b5')
-_dockerimage="linuxserver/codimd:1.5.0-ls12"
+_dockerimage="quay.io/codimd/server:${pkgver}"
prepare() {
rm -f codimd.tar
- skopeo copy "docker://${_dockerimage}" "docker-archive:${srcdir}/codimd.tar:latest"
+ skopeo copy "docker://${_dockerimage}" docker-archive:codimd.tar:latest
}
package() {
diff --git a/codimd.service b/codimd.service
index 0d11dbb1e047..1ef35ad5b7c9 100644
--- a/codimd.service
+++ b/codimd.service
@@ -4,13 +4,15 @@ Description=Realtime collaborative markdown notes
[Service]
Type=simple
RootDirectory=/opt/codimd
-WorkingDirectory=/opt/codimd
+WorkingDirectory=/codimd
EnvironmentFile=/etc/codimd/environment
-ExecStartPre=/opt/codimd/node_modules/sequelize-cli/lib/sequelize db:migrate --url ${CMD_DB_URL}
-ExecStart=/usr/bin/node app.js
+ExecStartPre=/codimd/node_modules/.bin/sequelize db:migrate --url ${CMD_DB_URL}
+ExecStart=/usr/local/bin/node app.js
User=codimd
ConfigurationDirectory=codimd
+RuntimeDirectory=codimd
StateDirectory=codimd codimd/uploads
+BindReadOnlyPaths=/etc/resolv.conf
MountAPIVFS=true
NoNewPrivileges=true
ProtectKernelTunables=true
diff --git a/config.json b/config.json
index 7a8a1be06c7c..9875eebcc660 100644
--- a/config.json
+++ b/config.json
@@ -4,14 +4,15 @@
"hsts": {
"enable": false
},
- "uploadsPath": "/var/lib/codimd/uploads"
+ "uploadsPath": "/var/lib/codimd/uploads",
+ "tmpPath": "/tmp"
},
"production": {
"loglevel": "info",
"hsts": {
"enable": true,
"maxAgeSeconds": 31536000,
- "includeSubdomains": true,
+ "includeSubDomains": true,
"preload": true
},
"csp": {
@@ -23,6 +24,7 @@
"addDisqus": false,
"addGoogleAnalytics": false
},
- "uploadsPath": "/var/lib/codimd/uploads"
+ "uploadsPath": "/var/lib/codimd/uploads",
+ "tmpPath": "/tmp"
}
}
diff --git a/environment b/environment
index 36059513002d..bb622b20cdc3 100644
--- a/environment
+++ b/environment
@@ -188,6 +188,7 @@ CMD_ALLOW_EMAIL_REGISTER=true
#CMD_GOOGLE_CLIENTID=
#CMD_GOOGLE_CLIENTSECRET=
+#CMD_GOOGLE_HOSTEDDOMAIN=
## LDAP Login