summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-04-14 06:38:02 +0200
committerKlaus Alexander Seistrup2023-04-14 06:38:02 +0200
commitae8a71df607cf521f645ff8aaf4a9a62d346e45b (patch)
treedd7bf9b82f9352bf8c49ff112244f852c97a1590
parent14742834ba6f6eafc9783939f2683c9601a01a7b (diff)
downloadaur-ae8a71df607cf521f645ff8aaf4a9a62d346e45b.tar.gz
New upstream release: v0.16.0
Release notes: * https://github.com/exaloop/codon/releases/tag/v0.16.0 * https://docs.exaloop.io/codon/general/releases#v0.16
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD17
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5599c55108d2..41cfe46272a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,34 @@
pkgbase = codon-bin
pkgdesc = High-performance, zero-overhead, extensible Python compiler using LLVM
- pkgver = 0.15.5
+ pkgver = 0.16.0
pkgrel = 1
url = https://github.com/exaloop/codon
arch = x86_64
license = custom:Business Source License 1.1
- depends = openmp
+ depends = cython
+ depends = gcc-libs
+ depends = glibc
+ depends = python
+ depends = python-astunparse
depends = python-setuptools
+ depends = sh
provides = codon
conflicts = codon
- noextract = codon-0.15.5.tar.gz
+ noextract = codon-0.16.0.tar.gz
source = codon.sh
- source = codon-0.15.5.tar.gz::https://github.com/exaloop/codon/releases/download/v0.15.5/codon-linux-x86_64.tar.gz
+ source = codon-0.16.0.tar.gz::https://github.com/exaloop/codon/releases/download/v0.16.0/codon-linux-x86_64.tar.gz
source = https://raw.githubusercontent.com/exaloop/codon/develop/LICENSE
source = https://raw.githubusercontent.com/exaloop/codon/develop/README.md
sha256sums = ac8fa16770f809daf61c3726194b71c0561791a83831a246fab4929ef6395d9f
- sha256sums = 957b6a27c0cc6c987d9d302954c93241314007856053c25a2116582774959198
+ sha256sums = 38c5cf4a31cdf3ff63073172fa55f62f72783c527bc45e4a42186a1ae4778ba5
sha256sums = SKIP
sha256sums = SKIP
sha512sums = cc4b100f55a02a0f7a6920668f7ab58986c2c77e76eab20e94def42ac740f054c450bc6d6ec11535db31e16fc32fa934d697f01bae9dfe5796e3d2f1c807f446
- sha512sums = 8fb2a7b63979fef98f69c7ea46f0443d1b160dfe7fe40785c864577384291819dd968958fd32f4e376d55ef145d8a2ad033fce12660c58933004e420192b3df9
+ sha512sums = 0c5c744d6a81aeee00168003b751b0cd22527391e8719e979ffa160ad248ef2a9f707f7b788a73eef3124bcf20b73261a820a952bb525649e24235daa1b76c58
sha512sums = SKIP
sha512sums = SKIP
b2sums = 718328c0651e383b892e7c1f00b795f88c6f4775b02e3a2ba217873d105e51824f380ba55b8602d1698da12ee3609641a753a6aa7660d5d4df52ea855eca5ca7
- b2sums = aa423f97dabecc81a4691eaa8379b7b73129b12de1538e0cd7f8dab566804fb692e373d647c1f59f3de00cd1e62bfffd8b65219b85c39cf1a83354d80e5a9f9c
+ b2sums = 91afda73665f8e65f35e8aaeb3a8b35f275db9a06c662506fc4a8e6121a5c759a2c4b99539d2000d7cc2a731fca4d2cf83952edb7870a37754e8055886f0a6d1
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0b883da2fa5a..ee7c723045b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='codon-bin'
_pkgname="${pkgname%%-bin}"
-pkgver=0.15.5
+pkgver=0.16.0
pkgrel=1
pkgdesc='High-performance, zero-overhead, extensible Python compiler using LLVM'
arch=('x86_64')
@@ -11,8 +11,13 @@ url='https://github.com/exaloop/codon'
_rawurl='https://raw.githubusercontent.com/exaloop/codon/develop'
license=('custom:Business Source License 1.1')
depends=(
- 'openmp'
+ 'cython'
+ 'gcc-libs'
+ 'glibc'
+ 'python'
+ 'python-astunparse'
'python-setuptools'
+ 'sh'
)
provides=('codon')
conflicts=('codon')
@@ -38,18 +43,18 @@ package() {
sha256sums=(
'ac8fa16770f809daf61c3726194b71c0561791a83831a246fab4929ef6395d9f'
- '957b6a27c0cc6c987d9d302954c93241314007856053c25a2116582774959198'
+ '38c5cf4a31cdf3ff63073172fa55f62f72783c527bc45e4a42186a1ae4778ba5'
'SKIP' 'SKIP'
)
sha512sums=(
'cc4b100f55a02a0f7a6920668f7ab58986c2c77e76eab20e94def42ac740f054c450bc6d6ec11535db31e16fc32fa934d697f01bae9dfe5796e3d2f1c807f446'
- '8fb2a7b63979fef98f69c7ea46f0443d1b160dfe7fe40785c864577384291819dd968958fd32f4e376d55ef145d8a2ad033fce12660c58933004e420192b3df9'
+ '0c5c744d6a81aeee00168003b751b0cd22527391e8719e979ffa160ad248ef2a9f707f7b788a73eef3124bcf20b73261a820a952bb525649e24235daa1b76c58'
'SKIP' 'SKIP'
)
b2sums=(
'718328c0651e383b892e7c1f00b795f88c6f4775b02e3a2ba217873d105e51824f380ba55b8602d1698da12ee3609641a753a6aa7660d5d4df52ea855eca5ca7'
- 'aa423f97dabecc81a4691eaa8379b7b73129b12de1538e0cd7f8dab566804fb692e373d647c1f59f3de00cd1e62bfffd8b65219b85c39cf1a83354d80e5a9f9c'
- 'SKIP' 'SKIP'
+ '91afda73665f8e65f35e8aaeb3a8b35f275db9a06c662506fc4a8e6121a5c759a2c4b99539d2000d7cc2a731fca4d2cf83952edb7870a37754e8055886f0a6d1'
+ 'SKIP' 'SKIP' # Skip to my Lou
)
# eof