summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Orcsik2015-12-16 13:00:58 +0100
committerMarius Orcsik2015-12-16 13:00:58 +0100
commit552621a9833dd006e60e441cd75834898362b6ce (patch)
tree92be0a5eb7f8a7f9937c18cb858edf0d813ce370
downloadaur-552621a9833dd006e60e441cd75834898362b6ce.tar.gz
Initial commit
Using version 2 alpha 3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
-rw-r--r--coedit.desktop12
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c4c894253fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Dec 16 11:51:53 UTC 2015
+pkgbase = coedit-bin
+ pkgdesc = Coedit is an IDE for the DMD D2 compiler.
+ pkgver = 2_alpha_3
+ pkgrel = 1
+ url = https://github.com/BBasile/Coedit
+ arch = x86
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ optdepends = dlang
+ provides = coedit
+ source = https://github.com/BBasile/Coedit/releases/download/2_alpha_3/coedit.2alpha3.linux32.zip
+ md5sums = e78bfa6f56f9e85713d8d509bcba1fab
+
+pkgname = coedit-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08cf60a346cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marius O<marius@habarnam.ro>
+pkgname=coedit-bin
+pkgver=2_alpha_3
+pkgrel=1
+pkgdesc="Coedit is an IDE for the DMD D2 compiler."
+url="https://github.com/BBasile/Coedit"
+license=('MIT')
+makedepends=("unzip")
+optdepends=("dlang")
+provides=("coedit")
+arch=("x86" "x86_64")
+if test "$CARCH" == x86_64; then
+ _arch="64"
+else
+ _arch="32"
+fi
+source=("https://github.com/BBasile/Coedit/releases/download/${pkgver}/${pkgname%-bin}.${pkgver//_}.linux${_arch}.zip")
+md5sums=('e78bfa6f56f9e85713d8d509bcba1fab')
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/icons"
+ mkdir -p "${pkgdir}/usr/share/applications"
+
+ cp coedit "${pkgdir}/usr/bin"
+ cp cesyms "${pkgdir}/usr/bin"
+ cp cetodo "${pkgdir}/usr/bin"
+ cp coedit.png "${pkgdir}/usr/share/icons"
+ cp ../coedit.desktop "${pkgdir}/usr/share/applications"
+}
diff --git a/coedit.desktop b/coedit.desktop
new file mode 100644
index 000000000000..b2474ff19417
--- /dev/null
+++ b/coedit.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0;
+Type=Application
+Categories=Development;IDE;
+Exec=coedit
+Terminal=false
+MimeType=text/x-dsrc;
+Patterns=*.d;*.D;
+GenericName=D Language IDE
+X-MultipleArgs=false
+Icon=coedit
+Name=Coedit