summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-12-11 19:13:48 +0100
committerhaawda2020-12-11 19:13:48 +0100
commitf99fee69d57335a6af05853b9db4f76a09dd1178 (patch)
treec7267a6014de13a8edb37dba2f0c7f250a58e490
parent1956f521b97b0ffd2597821c5afb25d88f0a20d2 (diff)
downloadaur-f99fee69d57335a6af05853b9db4f76a09dd1178.tar.gz
take fixes from [community] package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d790f9ce0243..cee4b2eb5836 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = coffeescript-git
pkgdesc = Language that compiles into JavaScript
pkgver = 2.5.1.r5.g07f644c3
- pkgrel = 1
+ pkgrel = 2
url = http://coffeescript.org
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 0d3839708ac6..6c6243a7d77a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=coffeescript-git
pkgver=2.5.1.r5.g07f644c3
-pkgrel=1
+pkgrel=2
pkgdesc='Language that compiles into JavaScript'
arch=('any')
url=http://coffeescript.org
@@ -23,5 +23,13 @@ pkgver() {
package() {
cd ${pkgname%-git}
npm install --global --user root --prefix "$pkgdir"/usr coffeescript
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
+ chmod -R u=rwX,go=rX "$pkgdir"
+
+ # npm installs package.json owned by build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "$pkgdir"
+ # license file
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}