summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Giammarchi2020-10-09 07:47:29 +0200
committerAndrea Giammarchi2020-10-09 07:47:29 +0200
commitd03e7a250a3bfe86195b1011777a07053d5be6e8 (patch)
treec422711d825d08ff79380c0ffb00cf5dda4e1666
downloadaur-d03e7a250a3bfe86195b1011777a07053d5be6e8.tar.gz
Updated cog-wpe-bin
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD24
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9851105fe46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = cog-wpe-bin
+ pkgdesc = WPE launcher and webapp container
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/Igalia/cog
+ arch = aarch64
+ arch = armv7h
+ arch = armv7l
+ arch = x86_64
+ groups = wpe
+ license = custom:MIT
+ depends = wpewebkit-bin
+ depends = wpebackend-fdo
+ depends = libinput
+ provides = cog
+ provides = cog-git
+ conflicts = cog
+ conflicts = cog-git
+ source_aarch64 = cog-wpe-bin-aarch64::https://webreflection.github.io/aur/cog-wpe-bin-aarch640.8.0.tar.gz
+ sha256sums_aarch64 = e4fbd01be7b57c953e4e2ed81edd4f2bec7061890af30e839b751871af76430f
+ source_armv7h = cog-wpe-bin-armv7h::https://webreflection.github.io/aur/cog-wpe-bin-armv7l0.8.0.tar.gz
+ sha256sums_armv7h = af5f3511da67bebd224034fc1e2f9e2ffedfa2096c131ddc85652c7e258c333f
+ source_armv7l = cog-wpe-bin-armv7l::https://webreflection.github.io/aur/cog-wpe-bin-armv7l0.8.0.tar.gz
+ sha256sums_armv7l = af5f3511da67bebd224034fc1e2f9e2ffedfa2096c131ddc85652c7e258c333f
+ source_x86_64 = cog-wpe-bin-x86::https://webreflection.github.io/aur/cog-wpe-bin-x86_640.8.0.tar.gz
+ sha256sums_x86_64 = 2ceb11ed2633d5b2255856d04440b5273fe44e6862ced7b169c239d8cf6e8afa
+
+pkgname = cog-wpe-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de0e3528d3a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Andrea Giammarchi <andrea.giammarchi@gmail.com>
+pkgdesc='WPE launcher and webapp container'
+pkgname=cog-wpe-bin
+pkgver=0.8.0
+arch=(aarch64 armv7h armv7l x86_64)
+pkgrel=1
+url=https://github.com/Igalia/cog
+license=(custom:MIT)
+groups=(wpe)
+provides=(cog cog-git)
+conflicts=(cog cog-git)
+depends=(wpewebkit-bin wpebackend-fdo libinput)
+source_aarch64=("${pkgname}-aarch64::https://webreflection.github.io/aur/${pkgname}-aarch64${pkgver}.tar.gz")
+source_armv7h=("${pkgname}-armv7h::https://webreflection.github.io/aur/${pkgname}-armv7l${pkgver}.tar.gz")
+source_armv7l=("${pkgname}-armv7l::https://webreflection.github.io/aur/${pkgname}-armv7l${pkgver}.tar.gz")
+source_x86_64=("${pkgname}-x86::https://webreflection.github.io/aur/${pkgname}-x86_64${pkgver}.tar.gz")
+sha256sums_aarch64=('e4fbd01be7b57c953e4e2ed81edd4f2bec7061890af30e839b751871af76430f')
+sha256sums_armv7h=('af5f3511da67bebd224034fc1e2f9e2ffedfa2096c131ddc85652c7e258c333f')
+sha256sums_armv7l=('af5f3511da67bebd224034fc1e2f9e2ffedfa2096c131ddc85652c7e258c333f')
+sha256sums_x86_64=('2ceb11ed2633d5b2255856d04440b5273fe44e6862ced7b169c239d8cf6e8afa')
+
+package () {
+ cp -R "${srcdir}/usr" "${pkgdir}"
+}