summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ08nY2016-09-06 01:20:15 +0200
committerJ08nY2016-09-06 01:22:50 +0200
commit1e84f641a9dea4eb2e08d9387961e9358450f22d (patch)
tree5cdc49d20f40d4eb45c6efdee298c85b791bbd34
parent5f7c23e74b9b7bef60a8e75e40ec96466fc93ed4 (diff)
downloadaur-1e84f641a9dea4eb2e08d9387961e9358450f22d.tar.gz
Fixed Twisted dependency issue (3cf8d89)
https://github.com/coherence-project/Coherence/commit/3cf8d89cbb44b5c7a0693d0b5d665e68acc3927c
-rw-r--r--PKGBUILD7
-rw-r--r--twisted_detection.patch10
2 files changed, 15 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f52e32fe47fd..016b1db72411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
pkgname=coherence
pkgver=0.6.6.2
-pkgrel=5
+pkgrel=6
pkgdesc="A DLNA/UPnP MediaServer and MediaRenderer"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://coherence.beebits.net/"
license=('MIT')
depends=('python2' 'twisted-web2' 'python-elementtree' 'python2-configobj' 'libcaca')
@@ -30,6 +30,7 @@ source=(http://coherence.beebits.net/download/Coherence-${pkgver}.tar.gz
coherence.service
coherence_pidfile.patch
samsung.patch
+ twisted_detection.patch
org.Coherence.service)
backup=('etc/coherence.conf')
md5sums=('d7a1b4abf6831c61e37a3b9e2bdc560a'
@@ -37,6 +38,7 @@ md5sums=('d7a1b4abf6831c61e37a3b9e2bdc560a'
'c43416ac2fb8a8195917a7e23b806c7d'
'b12f5f89fe34e48267c6c6e7cab5a4f4'
'039d4b84c0f0d023d9e9519fba1b101e'
+ '7ad9e42ab1e6dc8efa850d4b348e3052'
'ed11837f08988600e5aac0caf8e5221a')
prepare() {
@@ -44,6 +46,7 @@ prepare() {
patch -Np0 -i "$srcdir/samsung.patch"
patch -p1 -i "$srcdir/coherence_pidfile.patch"
+ patch -Np0 -i "$srcdir/twisted_detection.patch"
}
package() {
diff --git a/twisted_detection.patch b/twisted_detection.patch
new file mode 100644
index 000000000000..27d2010c432c
--- /dev/null
+++ b/twisted_detection.patch
@@ -0,0 +1,10 @@
+--- coherence/__init__.py
+@@ -24,8 +24,6 @@
+ if twisted_version < Version("twisted", 2, 5, 0):
+ raise ImportError("Twisted >= 2.5 is required. Please install it.")
+
+- if twisted_web_version < Version("twisted.web", 2, 5, 0):
+- raise ImportError("Twisted.Web >= 2.5 is required. Please install it")
+ except ImportError, exc:
+ # log error to stderr, might be useful for debugging purpose
+ for arg in exc.args: