summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2018-04-02 17:06:16 +0200
committerGabriel Souza Franco2018-04-02 17:06:16 +0200
commit3821c7ec6f5ce9d2c16eb06aa993ddc4052af1a4 (patch)
tree49c263ba61b01f0fe52cf1c314412561e8fadf84
parent8ac9b04322205b5f401bdb61267d29b62b3d7a42 (diff)
downloadaur-3821c7ec6f5ce9d2c16eb06aa993ddc4052af1a4.tar.gz
Fix crash at startup
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--gcc6-crash-fix.patch28
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e51a246bef95..b0b8afd64bad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = coin
pkgdesc = A high-level 3D graphics toolkit on top of OpenGL
pkgver = 3.1.3
- pkgrel = 15
+ pkgrel = 16
url = http://www.coin3d.org/
arch = i686
arch = x86_64
@@ -17,8 +17,10 @@ pkgbase = coin
optdepends = simage: image format support
source = https://bitbucket.org/Coin3D/coin/downloads/Coin-3.1.3.tar.gz
source = fixed-wrong-assignment.patch
+ source = gcc6-crash-fix.patch
sha256sums = 583478c581317862aa03a19f14c527c3888478a06284b9a46a0155fa5886d417
sha256sums = f71a13da97f6000ce66a63ae780a67226bcd906f9abf289436ea6e218d77fae0
+ sha256sums = 23326a4790f7a9c9654bd114baec400386a350bf49450c72c17a369056287c53
pkgname = coin
diff --git a/PKGBUILD b/PKGBUILD
index 384a4c12423f..435f6752f46c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=coin
pkgver=3.1.3
-pkgrel=15
+pkgrel=16
pkgdesc='A high-level 3D graphics toolkit on top of OpenGL'
url='http://www.coin3d.org/'
license=('GPL')
@@ -21,9 +21,11 @@ optdepends=('openal: sound/dynamic linking support'
'js: dynamic linking support'
'simage: image format support')
source=("https://bitbucket.org/Coin3D/coin/downloads/Coin-${pkgver}.tar.gz"
- 'fixed-wrong-assignment.patch')
+ 'fixed-wrong-assignment.patch'
+ 'gcc6-crash-fix.patch')
sha256sums=('583478c581317862aa03a19f14c527c3888478a06284b9a46a0155fa5886d417'
- 'f71a13da97f6000ce66a63ae780a67226bcd906f9abf289436ea6e218d77fae0')
+ 'f71a13da97f6000ce66a63ae780a67226bcd906f9abf289436ea6e218d77fae0'
+ '23326a4790f7a9c9654bd114baec400386a350bf49450c72c17a369056287c53')
prepare() {
cd Coin-${pkgver}
@@ -39,6 +41,9 @@ prepare() {
# fixes char to pointer assignment
patch -i "$srcdir/fixed-wrong-assignment.patch" -p1
+
+ # fix crash at startup
+ patch -i "$srcdir/gcc6-crash-fix.patch" -p1
}
build() {
diff --git a/gcc6-crash-fix.patch b/gcc6-crash-fix.patch
new file mode 100644
index 000000000000..4f338f7bdc56
--- /dev/null
+++ b/gcc6-crash-fix.patch
@@ -0,0 +1,28 @@
+# HG changeset patch
+# User Volker Enderlein <volkerenderlein@hotmail.com>
+# Date 1503595317 -7200
+# Node ID 7ba0af2dabad860d2957f770e86a7e15e7432e9f
+# Parent 10d8002bcf0df2ac8327b40435215b1a112fef8e
+Added fix for issue #128 provided by Fedora devs to SbHash.h
+
+diff --git a/src/misc/SbHash.h b/src/misc/SbHash.h
+--- a/src/misc/SbHash.h
++++ b/src/misc/SbHash.h
+@@ -89,6 +89,8 @@
+ cc_memalloc_deallocate(entry->memhandler, ptr);
+ }
+ SbHashEntry(const Key & key, const Type & obj) : key(key), obj(obj) {}
++ SbHashEntry(const Key & key, const Type & obj, cc_memalloc *memhandler)
++ : key(key), obj(obj), memhandler(memhandler) {}
+
+ Key key;
+ Type obj;
+@@ -218,7 +218,7 @@
+ /* Key not already in the hash table; insert a new
+ * entry as the first element in the bucket
+ */
+- entry = new (this->memhandler) SbHashEntry<Type, Key>(key, obj);
++ entry = new (this->memhandler) SbHashEntry<Type, Key>(key, obj, this->memhandler);
+ entry->next = this->buckets[i];
+ this->buckets[i] = entry;
+