summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2020-01-23 10:36:42 -0300
committerGabriel Souza Franco2020-01-23 10:36:42 -0300
commit3d7b169fff34a8ed601bc70d9db929a23d990a02 (patch)
tree4910e72ba8e332561d88abc8a1d71d5de3ec8a42
parent4bfb1b81939aa32d3614e6a6056e6f28333c6e5a (diff)
downloadaur-3d7b169fff34a8ed601bc70d9db929a23d990a02.tar.gz
Update to new upstream release
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
-rw-r--r--fixed-wrong-assignment.patch29
-rw-r--r--gcc6-crash-fix.patch28
-rw-r--r--remove-expat.patch260
6 files changed, 22 insertions, 338 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d501b89895bd..020fcd9eba15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = coin
pkgdesc = A high-level 3D graphics toolkit on top of OpenGL
- pkgver = 4.0.0a+11927+me74da184f75b
+ pkgver = 4.0.0
pkgrel = 1
url = https://bitbucket.org/Coin3D/coin
arch = i686
arch = x86_64
license = GPL
- makedepends = mercurial
makedepends = cmake
makedepends = doxygen
makedepends = glu
@@ -15,12 +14,10 @@ pkgbase = coin
optdepends = fontconfig: dynamic linking support
optdepends = zlib: dynamic linking support
optdepends = freetype2: dynamic linking support
- source = coin::hg+https://bitbucket.org/Coin3D/coin#revision=e74da184f75b
- source = generalmsvcgeneration::hg+https://bitbucket.org/Coin3D/generalmsvcgeneration
- source = boost-header-libs-full::hg+https://bitbucket.org/Coin3D/boost-header-libs-full
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = https://github.com/coin3d/coin/archive/Coin-4.0.0.tar.gz
+ source = coin-remove-cpack.patch::https://github.com/coin3d/coin/commit/be8e3d5.patch
+ sha256sums = b00d2a8e9d962397cf9bf0d9baa81bcecfbd16eef675a98c792f5cf49eb6e805
+ sha256sums = c77a6bbcaef4d65b45eac7711d3be713d4d23699d63a38f57030febb4b16e24d
pkgname = coin
optdepends = openal: sound/dynamic linking support
diff --git a/.gitignore b/.gitignore
index 4c6c87a07722..54aca4e90938 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-coin/
-boost-header-libs-full/
-generalmsvcgeneration/
+Coin-*.tar.gz
*.pkg.*
+*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 5a34eb8f7a54..148000cf0895 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,34 +7,39 @@
pkgbase=coin
pkgname=(coin coin-docs)
-_count=11927
-_rev=e74da184f75b
-pkgver=4.0.0a+$_count+m$_rev
+pkgver=4.0.0
pkgrel=1
pkgdesc='A high-level 3D graphics toolkit on top of OpenGL'
url='https://bitbucket.org/Coin3D/coin'
license=('GPL')
arch=('i686' 'x86_64')
depends=('libgl')
-makedepends=('mercurial' 'cmake' 'doxygen' 'glu')
+makedepends=('cmake' 'doxygen' 'glu')
optdepends=('openal: sound/dynamic linking support'
'fontconfig: dynamic linking support'
'zlib: dynamic linking support'
'freetype2: dynamic linking support')
-source=("coin::hg+https://bitbucket.org/Coin3D/coin#revision=$_rev"
- "generalmsvcgeneration::hg+https://bitbucket.org/Coin3D/generalmsvcgeneration"
- "boost-header-libs-full::hg+https://bitbucket.org/Coin3D/boost-header-libs-full")
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+source=("https://github.com/coin3d/coin/archive/Coin-$pkgver.tar.gz"
+ "coin-remove-cpack.patch::https://github.com/coin3d/coin/commit/be8e3d5.patch")
+sha256sums=('b00d2a8e9d962397cf9bf0d9baa81bcecfbd16eef675a98c792f5cf49eb6e805'
+ 'c77a6bbcaef4d65b45eac7711d3be713d4d23699d63a38f57030febb4b16e24d')
+
+prepare() {
+ cd coin-Coin-$pkgver
+
+ patch -Np1 -i ../coin-remove-cpack.patch
+}
build() {
mkdir -p build
cd build
- cmake ../coin \
+ cmake ../coin-Coin-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCOIN_THREADSAFE=ON \
- -DCOIN_BUILD_DOCUMENTATION_CHM=ON \
+ -DCOIN_BUILD_DOCUMENTATION=ON \
+ -DCOIN_BUILD_DOCUMENTATION_CHM=OFF \
-DCOIN_BUILD_DOCUMENTATION_MAN=ON \
-DUSE_EXTERNAL_EXPAT=ON
diff --git a/fixed-wrong-assignment.patch b/fixed-wrong-assignment.patch
deleted file mode 100644
index b0da72e40e51..000000000000
--- a/fixed-wrong-assignment.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-# HG changeset patch
-# User Giampiero Gabbiani <giampiero@gabbiani.org>
-# Date 1504091210 -7200
-# Branch fedora26-adaptations
-# Node ID 6008c4bd6ba67387bffde6b2b23e7aa01f137e9c
-# Parent fbd6ca1c14368c388e177f5a7103378dd22b4296
-fixed wrong assignment to buffer pointer
-
-diff --git a/src/3ds/SoStream.cpp b/src/3ds/SoStream.cpp
---- a/src/3ds/SoStream.cpp
-+++ b/src/3ds/SoStream.cpp
-@@ -185,7 +185,7 @@
- if (!gotNum) { setBadBit(); return FALSE; } \
- \
- char *ce; \
-- s = '\0'; \
-+ *s = '\0'; \
- _convertType_ tempVal = _convertFunc_(buf, &ce, 0); \
- \
- if (ce != s) \
-@@ -282,7 +282,7 @@
- gotAll: \
- \
- char *ce; \
-- s = '\0'; \
-+ *s = '\0'; \
- double tempVal = _convertFunc_(buf, &ce); \
- \
- if (ce != s) \
diff --git a/gcc6-crash-fix.patch b/gcc6-crash-fix.patch
deleted file mode 100644
index 4f338f7bdc56..000000000000
--- a/gcc6-crash-fix.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-# HG changeset patch
-# User Volker Enderlein <volkerenderlein@hotmail.com>
-# Date 1503595317 -7200
-# Node ID 7ba0af2dabad860d2957f770e86a7e15e7432e9f
-# Parent 10d8002bcf0df2ac8327b40435215b1a112fef8e
-Added fix for issue #128 provided by Fedora devs to SbHash.h
-
-diff --git a/src/misc/SbHash.h b/src/misc/SbHash.h
---- a/src/misc/SbHash.h
-+++ b/src/misc/SbHash.h
-@@ -89,6 +89,8 @@
- cc_memalloc_deallocate(entry->memhandler, ptr);
- }
- SbHashEntry(const Key & key, const Type & obj) : key(key), obj(obj) {}
-+ SbHashEntry(const Key & key, const Type & obj, cc_memalloc *memhandler)
-+ : key(key), obj(obj), memhandler(memhandler) {}
-
- Key key;
- Type obj;
-@@ -218,7 +218,7 @@
- /* Key not already in the hash table; insert a new
- * entry as the first element in the bucket
- */
-- entry = new (this->memhandler) SbHashEntry<Type, Key>(key, obj);
-+ entry = new (this->memhandler) SbHashEntry<Type, Key>(key, obj, this->memhandler);
- entry->next = this->buckets[i];
- this->buckets[i] = entry;
-
diff --git a/remove-expat.patch b/remove-expat.patch
deleted file mode 100644
index ea81e1a2129d..000000000000
--- a/remove-expat.patch
+++ /dev/null
@@ -1,260 +0,0 @@
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -81,7 +81,7 @@
- 3ds/libformat3ds.la collision/libcollision.la hardcopy/libhardcopy.la \
- threads/libthreads.la shaders/libshaders.la \
- shadows/libshadows.la geo/libgeo.la foreignfiles/libforeignfiles.la \
-- xml/libxml.la xml/expat/libexpat.la profiler/libprofiler.la \
-+ xml/libxml.la profiler/libprofiler.la \
- vrml97/libvrml97.la scxml/libscxml.la $(SUPERGLULIBADD)
- endif
- endif
-@@ -126,7 +126,6 @@
- geo/all-geo-cpp.cpp \
- foreignfiles/all-foreignfiles-cpp.cpp \
- xml/all-xml-cpp.cpp \
-- xml/expat/all-expat-c.c \
- profiler/all-profiler-cpp.cpp \
- vrml97/all-vrml97-cpp.cpp \
- scxml/all-scxml-cpp.cpp \
-@@ -162,7 +161,7 @@
- 3ds/format3ds.lst collision/collision.lst hardcopy/hardcopy.lst \
- threads/threads.lst shaders/shaders.lst \
- shadows/shadows.lst geo/geo.lst foreignfiles/foreignfiles.lst \
-- xml/xml.lst xml/expat/expat.lst profiler/profiler.lst \
-+ xml/xml.lst profiler/profiler.lst \
- vrml97/vrml97.lst scxml/scxml.lst $(SUPERGLULSTADD)
-
- # **************************************************************************
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -113,7 +113,7 @@
- collision/collision.lst hardcopy/hardcopy.lst \
- threads/threads.lst shaders/shaders.lst shadows/shadows.lst \
- geo/geo.lst foreignfiles/foreignfiles.lst xml/xml.lst \
-- xml/expat/expat.lst profiler/profiler.lst vrml97/vrml97.lst \
-+ profiler/profiler.lst vrml97/vrml97.lst \
- scxml/scxml.lst $(am__DEPENDENCIES_1)
- am__coin@COIN_MAJOR_VERSION@@SUFFIX@_lib_SOURCES_DIST = tidbits.cpp \
- share/gl/CoinGLPerformance.cpp actions/all-actions-cpp.cpp \
-@@ -134,7 +134,7 @@
- threads/all-threads-cpp.cpp shaders/all-shaders-cpp.cpp \
- shadows/all-shadows-cpp.cpp geo/all-geo-cpp.cpp \
- foreignfiles/all-foreignfiles-cpp.cpp xml/all-xml-cpp.cpp \
-- xml/expat/all-expat-c.c profiler/all-profiler-cpp.cpp \
-+ profiler/all-profiler-cpp.cpp \
- vrml97/all-vrml97-cpp.cpp scxml/all-scxml-cpp.cpp
- @MAC_FRAMEWORK_FALSE@am__objects_1 = tidbits.$(OBJEXT) \
- @MAC_FRAMEWORK_FALSE@ CoinGLPerformance.$(OBJEXT)
-@@ -173,7 +173,6 @@
- @MAC_FRAMEWORK_TRUE@ all-geo-cpp.$(OBJEXT) \
- @MAC_FRAMEWORK_TRUE@ all-foreignfiles-cpp.$(OBJEXT) \
- @MAC_FRAMEWORK_TRUE@ all-xml-cpp.$(OBJEXT) \
--@MAC_FRAMEWORK_TRUE@ all-expat-c.$(OBJEXT) \
- @MAC_FRAMEWORK_TRUE@ all-profiler-cpp.$(OBJEXT) \
- @MAC_FRAMEWORK_TRUE@ all-vrml97-cpp.$(OBJEXT) \
- @MAC_FRAMEWORK_TRUE@ all-scxml-cpp.$(OBJEXT) tidbits.$(OBJEXT) \
-@@ -218,7 +217,6 @@
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ geo/libgeo.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ foreignfiles/libforeignfiles.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ xml/libxml.la \
--@HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ xml/expat/libexpat.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ profiler/libprofiler.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ vrml97/libvrml97.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ scxml/libscxml.la \
-@@ -242,7 +240,7 @@
- threads/all-threads-cpp.cpp shaders/all-shaders-cpp.cpp \
- shadows/all-shadows-cpp.cpp geo/all-geo-cpp.cpp \
- foreignfiles/all-foreignfiles-cpp.cpp xml/all-xml-cpp.cpp \
-- xml/expat/all-expat-c.c profiler/all-profiler-cpp.cpp \
-+ profiler/all-profiler-cpp.cpp \
- vrml97/all-vrml97-cpp.cpp scxml/all-scxml-cpp.cpp
- @MAC_FRAMEWORK_FALSE@am__objects_3 = tidbits.lo CoinGLPerformance.lo
- @MAC_FRAMEWORK_TRUE@am__objects_3 = all-actions-cpp.lo all-base-cpp.lo \
-@@ -263,7 +261,7 @@
- @MAC_FRAMEWORK_TRUE@ all-threads-cpp.lo all-shaders-cpp.lo \
- @MAC_FRAMEWORK_TRUE@ all-shadows-cpp.lo all-geo-cpp.lo \
- @MAC_FRAMEWORK_TRUE@ all-foreignfiles-cpp.lo all-xml-cpp.lo \
--@MAC_FRAMEWORK_TRUE@ all-expat-c.lo all-profiler-cpp.lo \
-+@MAC_FRAMEWORK_TRUE@ all-profiler-cpp.lo \
- @MAC_FRAMEWORK_TRUE@ all-vrml97-cpp.lo all-scxml-cpp.lo \
- @MAC_FRAMEWORK_TRUE@ tidbits.lo CoinGLPerformance.lo
- am_libCoin@SUFFIX@_la_OBJECTS = $(am__objects_3)
-@@ -298,8 +296,6 @@
- @AMDEP_TRUE@ ./$(DEPDIR)/all-errors-cpp.Po \
- @AMDEP_TRUE@ ./$(DEPDIR)/all-events-cpp.Plo \
- @AMDEP_TRUE@ ./$(DEPDIR)/all-events-cpp.Po \
--@AMDEP_TRUE@ ./$(DEPDIR)/all-expat-c.Plo \
--@AMDEP_TRUE@ ./$(DEPDIR)/all-expat-c.Po \
- @AMDEP_TRUE@ ./$(DEPDIR)/all-fields-cpp.Plo \
- @AMDEP_TRUE@ ./$(DEPDIR)/all-fields-cpp.Po \
- @AMDEP_TRUE@ ./$(DEPDIR)/all-fonts-cpp.Plo \
-@@ -686,7 +682,7 @@
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ 3ds/libformat3ds.la collision/libcollision.la hardcopy/libhardcopy.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ threads/libthreads.la shaders/libshaders.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ shadows/libshadows.la geo/libgeo.la foreignfiles/libforeignfiles.la \
--@HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ xml/libxml.la xml/expat/libexpat.la profiler/libprofiler.la \
-+@HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ xml/libxml.la profiler/libprofiler.la \
- @HACKING_DYNAMIC_MODULES_FALSE@@MAC_FRAMEWORK_FALSE@ vrml97/libvrml97.la scxml/libscxml.la $(SUPERGLULIBADD)
-
- @HACKING_DYNAMIC_MODULES_TRUE@@MAC_FRAMEWORK_FALSE@libCoin@SUFFIX@_la_LIBADD =
-@@ -736,7 +732,6 @@
- @MAC_FRAMEWORK_TRUE@ geo/all-geo-cpp.cpp \
- @MAC_FRAMEWORK_TRUE@ foreignfiles/all-foreignfiles-cpp.cpp \
- @MAC_FRAMEWORK_TRUE@ xml/all-xml-cpp.cpp \
--@MAC_FRAMEWORK_TRUE@ xml/expat/all-expat-c.c \
- @MAC_FRAMEWORK_TRUE@ profiler/all-profiler-cpp.cpp \
- @MAC_FRAMEWORK_TRUE@ vrml97/all-vrml97-cpp.cpp \
- @MAC_FRAMEWORK_TRUE@ scxml/all-scxml-cpp.cpp \
-@@ -765,7 +760,7 @@
- 3ds/format3ds.lst collision/collision.lst hardcopy/hardcopy.lst \
- threads/threads.lst shaders/shaders.lst \
- shadows/shadows.lst geo/geo.lst foreignfiles/foreignfiles.lst \
-- xml/xml.lst xml/expat/expat.lst profiler/profiler.lst \
-+ xml/xml.lst profiler/profiler.lst \
- vrml97/vrml97.lst scxml/scxml.lst $(SUPERGLULSTADD)
-
- @MACOSX_10_2FF_FALSE@LibtoolLinkArgs = -no-undefined
-@@ -939,8 +934,6 @@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-errors-cpp.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-events-cpp.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-events-cpp.Po@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-expat-c.Plo@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-expat-c.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-fields-cpp.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-fields-cpp.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/all-fonts-cpp.Plo@am__quote@
-@@ -1042,30 +1035,6 @@
- @AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
- @am__fastdepCC_FALSE@ $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o all-engines-c.lo `test -f 'engines/all-engines-c.c' || echo '$(srcdir)/'`engines/all-engines-c.c
-
--all-expat-c.o: xml/expat/all-expat-c.c
--@am__fastdepCC_TRUE@ if $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT all-expat-c.o -MD -MP -MF "$(DEPDIR)/all-expat-c.Tpo" -c -o all-expat-c.o `test -f 'xml/expat/all-expat-c.c' || echo '$(srcdir)/'`xml/expat/all-expat-c.c; \
--@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/all-expat-c.Tpo" "$(DEPDIR)/all-expat-c.Po"; else rm -f "$(DEPDIR)/all-expat-c.Tpo"; exit 1; fi
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='xml/expat/all-expat-c.c' object='all-expat-c.o' libtool=no @AMDEPBACKSLASH@
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/all-expat-c.Po' tmpdepfile='$(DEPDIR)/all-expat-c.TPo' @AMDEPBACKSLASH@
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
--@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o all-expat-c.o `test -f 'xml/expat/all-expat-c.c' || echo '$(srcdir)/'`xml/expat/all-expat-c.c
--
--all-expat-c.obj: xml/expat/all-expat-c.c
--@am__fastdepCC_TRUE@ if $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT all-expat-c.obj -MD -MP -MF "$(DEPDIR)/all-expat-c.Tpo" -c -o all-expat-c.obj `if test -f 'xml/expat/all-expat-c.c'; then $(CYGPATH_W) 'xml/expat/all-expat-c.c'; else $(CYGPATH_W) '$(srcdir)/xml/expat/all-expat-c.c'; fi`; \
--@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/all-expat-c.Tpo" "$(DEPDIR)/all-expat-c.Po"; else rm -f "$(DEPDIR)/all-expat-c.Tpo"; exit 1; fi
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='xml/expat/all-expat-c.c' object='all-expat-c.obj' libtool=no @AMDEPBACKSLASH@
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/all-expat-c.Po' tmpdepfile='$(DEPDIR)/all-expat-c.TPo' @AMDEPBACKSLASH@
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
--@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o all-expat-c.obj `if test -f 'xml/expat/all-expat-c.c'; then $(CYGPATH_W) 'xml/expat/all-expat-c.c'; else $(CYGPATH_W) '$(srcdir)/xml/expat/all-expat-c.c'; fi`
--
--all-expat-c.lo: xml/expat/all-expat-c.c
--@am__fastdepCC_TRUE@ if $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT all-expat-c.lo -MD -MP -MF "$(DEPDIR)/all-expat-c.Tpo" -c -o all-expat-c.lo `test -f 'xml/expat/all-expat-c.c' || echo '$(srcdir)/'`xml/expat/all-expat-c.c; \
--@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/all-expat-c.Tpo" "$(DEPDIR)/all-expat-c.Plo"; else rm -f "$(DEPDIR)/all-expat-c.Tpo"; exit 1; fi
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='xml/expat/all-expat-c.c' object='all-expat-c.lo' libtool=yes @AMDEPBACKSLASH@
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/all-expat-c.Plo' tmpdepfile='$(DEPDIR)/all-expat-c.TPlo' @AMDEPBACKSLASH@
--@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
--@am__fastdepCC_FALSE@ $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o all-expat-c.lo `test -f 'xml/expat/all-expat-c.c' || echo '$(srcdir)/'`xml/expat/all-expat-c.c
--
- .cpp.o:
- @am__fastdepCXX_TRUE@ if $(CXXCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
- @am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
---- Coin-3.1.3/src/xml/Makefile.am 2010-03-02 15:20:09.000000000 +0200
-+++ Coin-3.1.3/src/xml/Makefile.am 2018-08-27 14:20:04.119896615 +0300
-@@ -1,6 +1,6 @@
- ## Process this file with automake to generate Makefile.in.
-
--SUBDIRS = expat
-+SUBDIRS =
-
- RegularSources = \
- document.cpp \
---- a/src/xml/Makefile.in
-+++ b/src/xml/Makefile.in
-@@ -422,7 +422,7 @@
- target_cpu = @target_cpu@
- target_os = @target_os@
- target_vendor = @target_vendor@
--SUBDIRS = expat
-+SUBDIRS =
- RegularSources = \
- document.cpp \
- element.cpp \
---- a/src/xml/document.cpp
-+++ b/src/xml/document.cpp
-@@ -42,8 +42,8 @@
- #include <Inventor/C/XML/parser.h>
- #include <Inventor/lists/SbList.h>
- #include <Inventor/SbString.h>
-+#include <expat.h>
-
--#include "expat/expat.h"
- #include "utils.h"
- #include "elementp.h"
-
---- a/configure
-+++ b/configure
-@@ -31523,7 +31523,7 @@
- elements/GL:glelements engines errors events fields fonts glue io \
- manips misc lists nodekits navigation nodes shapenodes projectors \
- sensors shaders upgraders hardcopy shadows geo foreignfiles collision \
-- xml xml/expat:expat profiler 3ds:format3ds scxml; \
-+ xml profiler 3ds:format3ds scxml; \
- do
- case $dir in
- *:* )
-@@ -32308,7 +32308,7 @@
-
- # **************************************************************************
-
--ac_config_files="$ac_config_files Makefile bin/Makefile include/Makefile include/Inventor/Makefile include/Inventor/C/Makefile include/Inventor/C/XML/Makefile include/Inventor/C/base/Makefile include/Inventor/C/errors/Makefile include/Inventor/C/glue/Makefile include/Inventor/C/threads/Makefile include/Inventor/VRMLnodes/Makefile include/Inventor/XML/Makefile include/Inventor/actions/Makefile include/Inventor/bundles/Makefile include/Inventor/caches/Makefile include/Inventor/collision/Makefile include/Inventor/details/Makefile include/Inventor/draggers/Makefile include/Inventor/elements/Makefile include/Inventor/engines/Makefile include/Inventor/errors/Makefile include/Inventor/events/Makefile include/Inventor/fields/Makefile include/Inventor/lists/Makefile include/Inventor/lock/Makefile include/Inventor/manips/Makefile include/Inventor/misc/Makefile include/Inventor/nodekits/Makefile include/Inventor/nodes/Makefile include/Inventor/projectors/Makefile include/Inventor/sensors/Makefile include/Inventor/system/Makefile include/Inventor/threads/Makefile include/Inventor/tools/Makefile include/Inventor/scxml/Makefile include/Inventor/annex/Makefile include/Inventor/annex/HardCopy/Makefile include/Inventor/annex/ForeignFiles/Makefile include/Inventor/annex/FXViz/Makefile include/Inventor/annex/FXViz/elements/Makefile include/Inventor/annex/FXViz/nodes/Makefile include/Inventor/annex/Profiler/Makefile include/Inventor/annex/Profiler/elements/Makefile include/Inventor/annex/Profiler/engines/Makefile include/Inventor/annex/Profiler/nodes/Makefile include/Inventor/annex/Profiler/nodekits/Makefile include/Inventor/annex/Profiler/utils/Makefile data/Makefile data/draggerDefaults/Makefile data/shaders/Makefile data/shaders/lights/Makefile data/shaders/vsm/Makefile data/scxml/Makefile data/scxml/navigation/Makefile man/Makefile man/man1/Makefile man/man3/Makefile html/Makefile src/Makefile src/base/Makefile src/actions/Makefile src/bundles/Makefile src/caches/Makefile src/collision/Makefile src/details/Makefile src/draggers/Makefile src/elements/Makefile src/elements/GL/Makefile src/engines/Makefile src/errors/Makefile src/events/Makefile src/fields/Makefile src/fonts/Makefile src/glue/Makefile src/io/Makefile src/manips/Makefile src/misc/Makefile src/lists/Makefile src/navigation/Makefile src/nodekits/Makefile src/nodes/Makefile src/projectors/Makefile src/3ds/Makefile src/sensors/Makefile src/upgraders/Makefile src/shapenodes/Makefile src/threads/Makefile src/extensions/Makefile src/vrml97/Makefile src/hardcopy/Makefile src/shaders/Makefile src/shadows/Makefile src/geo/Makefile src/foreignfiles/Makefile src/xml/Makefile src/xml/expat/Makefile src/profiler/Makefile src/scxml/Makefile src/doc/Makefile testsuite/Makefile cfg/gendsp.pl"
-+ac_config_files="$ac_config_files Makefile bin/Makefile include/Makefile include/Inventor/Makefile include/Inventor/C/Makefile include/Inventor/C/XML/Makefile include/Inventor/C/base/Makefile include/Inventor/C/errors/Makefile include/Inventor/C/glue/Makefile include/Inventor/C/threads/Makefile include/Inventor/VRMLnodes/Makefile include/Inventor/XML/Makefile include/Inventor/actions/Makefile include/Inventor/bundles/Makefile include/Inventor/caches/Makefile include/Inventor/collision/Makefile include/Inventor/details/Makefile include/Inventor/draggers/Makefile include/Inventor/elements/Makefile include/Inventor/engines/Makefile include/Inventor/errors/Makefile include/Inventor/events/Makefile include/Inventor/fields/Makefile include/Inventor/lists/Makefile include/Inventor/lock/Makefile include/Inventor/manips/Makefile include/Inventor/misc/Makefile include/Inventor/nodekits/Makefile include/Inventor/nodes/Makefile include/Inventor/projectors/Makefile include/Inventor/sensors/Makefile include/Inventor/system/Makefile include/Inventor/threads/Makefile include/Inventor/tools/Makefile include/Inventor/scxml/Makefile include/Inventor/annex/Makefile include/Inventor/annex/HardCopy/Makefile include/Inventor/annex/ForeignFiles/Makefile include/Inventor/annex/FXViz/Makefile include/Inventor/annex/FXViz/elements/Makefile include/Inventor/annex/FXViz/nodes/Makefile include/Inventor/annex/Profiler/Makefile include/Inventor/annex/Profiler/elements/Makefile include/Inventor/annex/Profiler/engines/Makefile include/Inventor/annex/Profiler/nodes/Makefile include/Inventor/annex/Profiler/nodekits/Makefile include/Inventor/annex/Profiler/utils/Makefile data/Makefile data/draggerDefaults/Makefile data/shaders/Makefile data/shaders/lights/Makefile data/shaders/vsm/Makefile data/scxml/Makefile data/scxml/navigation/Makefile man/Makefile man/man1/Makefile man/man3/Makefile html/Makefile src/Makefile src/base/Makefile src/actions/Makefile src/bundles/Makefile src/caches/Makefile src/collision/Makefile src/details/Makefile src/draggers/Makefile src/elements/Makefile src/elements/GL/Makefile src/engines/Makefile src/errors/Makefile src/events/Makefile src/fields/Makefile src/fonts/Makefile src/glue/Makefile src/io/Makefile src/manips/Makefile src/misc/Makefile src/lists/Makefile src/navigation/Makefile src/nodekits/Makefile src/nodes/Makefile src/projectors/Makefile src/3ds/Makefile src/sensors/Makefile src/upgraders/Makefile src/shapenodes/Makefile src/threads/Makefile src/extensions/Makefile src/vrml97/Makefile src/hardcopy/Makefile src/shaders/Makefile src/shadows/Makefile src/geo/Makefile src/foreignfiles/Makefile src/xml/Makefile src/profiler/Makefile src/scxml/Makefile src/doc/Makefile testsuite/Makefile cfg/gendsp.pl"
-
-
- cat >confcache <<\_ACEOF
-@@ -33211,7 +33211,6 @@
- "src/geo/Makefile") CONFIG_FILES="$CONFIG_FILES src/geo/Makefile" ;;
- "src/foreignfiles/Makefile") CONFIG_FILES="$CONFIG_FILES src/foreignfiles/Makefile" ;;
- "src/xml/Makefile") CONFIG_FILES="$CONFIG_FILES src/xml/Makefile" ;;
-- "src/xml/expat/Makefile") CONFIG_FILES="$CONFIG_FILES src/xml/expat/Makefile" ;;
- "src/profiler/Makefile") CONFIG_FILES="$CONFIG_FILES src/profiler/Makefile" ;;
- "src/scxml/Makefile") CONFIG_FILES="$CONFIG_FILES src/scxml/Makefile" ;;
- "src/doc/Makefile") CONFIG_FILES="$CONFIG_FILES src/doc/Makefile" ;;
---- a/configure.ac
-+++ b/configure.ac
-@@ -1951,7 +1951,7 @@
- elements/GL:glelements engines errors events fields fonts glue io \
- manips misc lists nodekits navigation nodes shapenodes projectors \
- sensors shaders upgraders hardcopy shadows geo foreignfiles collision \
-- xml xml/expat:expat profiler 3ds:format3ds scxml; \
-+ xml profiler 3ds:format3ds scxml; \
- do
- case $dir in
- *:* )
-@@ -2383,7 +2383,6 @@
- src/geo/Makefile
- src/foreignfiles/Makefile
- src/xml/Makefile
-- src/xml/expat/Makefile
- src/profiler/Makefile
- src/scxml/Makefile
- src/doc/Makefile
---- a/configure
-+++ b/configure
-@@ -21224,6 +21224,8 @@
- if $sim_ac_enable_system_expat; then
-
- $as_echo "#define HAVE_SYSTEM_EXPAT 1" >>confdefs.h
-+LIBS="$LIBS -lexpat"
-+COIN_EXTRA_LIBS="$COIN_EXTRA_LIBS -lexpat"
-
-
- if test x"${sim_ac_configuration_settings+set}" = x"set"; then
-diff -Nurb Coin-3.1.3.orig/configure.ac Coin-3.1.3/configure.ac
---- a/configure.ac
-+++ b/configure.ac
-@@ -434,6 +434,8 @@
- if $sim_ac_enable_system_expat; then
- AC_DEFINE([HAVE_SYSTEM_EXPAT], 1, [Define this if you want to use a system installation of expat])
- SIM_AC_CONFIGURATION_SETTING([Use system expat], [Yes])
-+ LIBS="$LIBS -lexpat"
-+ COIN_EXTRA_LIBS="$COIN_EXTRA_LIBS -lexpat"
- else
- SIM_AC_CONFIGURATION_SETTING([Use system expat], [No (default)])
- fi