summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2018-03-23 15:03:50 +0100
committerGabriel Souza Franco2018-03-23 15:03:50 +0100
commit8ac9b04322205b5f401bdb61267d29b62b3d7a42 (patch)
tree3a4b73f25923e5e46e0d143b33e6899a6fc36622
parentbac5fd8d3417fc111d45ef5dcfb66f824dfa7d42 (diff)
downloadaur-8ac9b04322205b5f401bdb61267d29b62b3d7a42.tar.gz
Fix build
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD20
-rw-r--r--fixed-wrong-assignment.patch29
4 files changed, 49 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a365db77687..e51a246bef95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Mar 22 09:39:36 UTC 2018
pkgbase = coin
pkgdesc = A high-level 3D graphics toolkit on top of OpenGL
pkgver = 3.1.3
- pkgrel = 14
+ pkgrel = 15
url = http://www.coin3d.org/
arch = i686
arch = x86_64
@@ -18,7 +16,9 @@ pkgbase = coin
optdepends = js: dynamic linking support
optdepends = simage: image format support
source = https://bitbucket.org/Coin3D/coin/downloads/Coin-3.1.3.tar.gz
+ source = fixed-wrong-assignment.patch
sha256sums = 583478c581317862aa03a19f14c527c3888478a06284b9a46a0155fa5886d417
+ sha256sums = f71a13da97f6000ce66a63ae780a67226bcd906f9abf289436ea6e218d77fae0
pkgname = coin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..013a46b919c1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index b41e42c9fbba..384a4c12423f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Florian Pritz <bluewind@xinu.at>
+# Maintainer: Gabriel Souza Franco <Z2FicmllbGZyYW5jb3NvdXphQGdtYWlsLmNvbQ==>
+# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Christian Hesse <mail@eworm.de>
# Contributor: Thomas Dziedzic < gostrc at gmail >
# Contributor: mickele
@@ -6,7 +7,7 @@
pkgname=coin
pkgver=3.1.3
-pkgrel=14
+pkgrel=15
pkgdesc='A high-level 3D graphics toolkit on top of OpenGL'
url='http://www.coin3d.org/'
license=('GPL')
@@ -19,10 +20,12 @@ optdepends=('openal: sound/dynamic linking support'
'freetype2: dynamic linking support'
'js: dynamic linking support'
'simage: image format support')
-source=("https://bitbucket.org/Coin3D/coin/downloads/Coin-${pkgver}.tar.gz")
-sha256sums=('583478c581317862aa03a19f14c527c3888478a06284b9a46a0155fa5886d417')
+source=("https://bitbucket.org/Coin3D/coin/downloads/Coin-${pkgver}.tar.gz"
+ 'fixed-wrong-assignment.patch')
+sha256sums=('583478c581317862aa03a19f14c527c3888478a06284b9a46a0155fa5886d417'
+ 'f71a13da97f6000ce66a63ae780a67226bcd906f9abf289436ea6e218d77fae0')
-build() {
+prepare() {
cd Coin-${pkgver}
# fix prefix in coin-config
@@ -34,6 +37,13 @@ build() {
# fix http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667139
sed -i '/^#include <Inventor\/C\/basic.h>$/i #include <Inventor/C/errors/debugerror.h>' include/Inventor/SbBasic.h
+ # fixes char to pointer assignment
+ patch -i "$srcdir/fixed-wrong-assignment.patch" -p1
+}
+
+build() {
+ cd Coin-${pkgver}
+
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
diff --git a/fixed-wrong-assignment.patch b/fixed-wrong-assignment.patch
new file mode 100644
index 000000000000..b0da72e40e51
--- /dev/null
+++ b/fixed-wrong-assignment.patch
@@ -0,0 +1,29 @@
+# HG changeset patch
+# User Giampiero Gabbiani <giampiero@gabbiani.org>
+# Date 1504091210 -7200
+# Branch fedora26-adaptations
+# Node ID 6008c4bd6ba67387bffde6b2b23e7aa01f137e9c
+# Parent fbd6ca1c14368c388e177f5a7103378dd22b4296
+fixed wrong assignment to buffer pointer
+
+diff --git a/src/3ds/SoStream.cpp b/src/3ds/SoStream.cpp
+--- a/src/3ds/SoStream.cpp
++++ b/src/3ds/SoStream.cpp
+@@ -185,7 +185,7 @@
+ if (!gotNum) { setBadBit(); return FALSE; } \
+ \
+ char *ce; \
+- s = '\0'; \
++ *s = '\0'; \
+ _convertType_ tempVal = _convertFunc_(buf, &ce, 0); \
+ \
+ if (ce != s) \
+@@ -282,7 +282,7 @@
+ gotAll: \
+ \
+ char *ce; \
+- s = '\0'; \
++ *s = '\0'; \
+ double tempVal = _convertFunc_(buf, &ce); \
+ \
+ if (ce != s) \