summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Ulianko2018-03-10 22:28:47 +0100
committerMichal Ulianko2018-03-10 22:28:47 +0100
commit0289ad45730a80c8acb4778027b4789b3e95b300 (patch)
treeea14710cd4453e4836e717ff1202200708294ddd
downloadaur-0289ad45730a80c8acb4778027b4789b3e95b300.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02a00568ebc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = coin-hg
+ pkgdesc = A high-level, retained-mode 3D graphics toolkit compatible with Open Inventor 2.1
+ pkgver = r11683.7e191c8f6a31
+ pkgrel = 1
+ url = https://bitbucket.org/Coin3D/coin
+ arch = x86_64
+ license = BSD
+ makedepends = mercurial
+ makedepends = cmake
+ makedepends = doxygen
+ depends = libgl
+ provides = coin
+ conflicts = coin
+ source = coin::hg+https://bitbucket.org/Coin3D/coin#branch=CMake
+ source = generalmsvcgeneration::hg+https://bitbucket.org/Coin3D/generalmsvcgeneration
+ source = boost-header-libs-full::hg+https://bitbucket.org/Coin3D/boost-header-libs-full
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = coin-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c55ab38eb55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Michal Ulianko <michal (dot) ulianko (at) gmail (dot) com>
+
+pkgname=coin-hg
+pkgver=r11683.7e191c8f6a31
+pkgrel=1
+pkgdesc="A high-level, retained-mode 3D graphics toolkit compatible with Open Inventor 2.1"
+arch=('x86_64')
+url="https://bitbucket.org/Coin3D/coin"
+license=('BSD')
+depends=('libgl')
+makedepends=('mercurial' 'cmake' 'doxygen')
+provides=("${pkgname%-hg}")
+conflicts=("${pkgname%-hg}")
+source=('coin::hg+https://bitbucket.org/Coin3D/coin#branch=CMake'
+ 'generalmsvcgeneration::hg+https://bitbucket.org/Coin3D/generalmsvcgeneration'
+ 'boost-header-libs-full::hg+https://bitbucket.org/Coin3D/boost-header-libs-full')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/coin"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "$srcdir/coin"
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="/usr/lib"
+ make
+}
+
+package() {
+ cd "$srcdir/coin"
+ make DESTDIR="$pkgdir/" install
+}