summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Balula2021-06-03 16:17:27 +0200
committerSamuel Balula2021-06-03 16:32:02 +0200
commit267a75a67ed51c3f9cad47727badf004b8672696 (patch)
tree45ce3568106f0d10d06dfced45704e83fa936fcb
parent0a221e18f4550c7420a8be5cd724b1f794c4a86e (diff)
downloadaur-267a75a67ed51c3f9cad47727badf004b8672696.tar.gz
PKGBUILD updated after Martin Constantin comments
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acd0d095c6d1..f0fabd53f091 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = coin-or-hsl
arch = x86_64
makedepends = gcc
makedepends = metis
+ makedepends = gcc-fortran
optdepends = openmp
optdepends = coin-or-ipopt
source = ThirdParty-HSL::git+https://github.com/coin-or-tools/ThirdParty-HSL.git
diff --git a/PKGBUILD b/PKGBUILD
index d05483f8b1c5..dea153cb0468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,10 @@
# Maintainer: Samuel Balula sbalula@ethz.ch
+# Intructions/ Troubleshoot
# Download the source from http://www.hsl.rl.ac.uk/ and place it in the folder, replacing the empty placeholder file
+# Check the sha256sum of the downloaded tarball, it may be different from the one listed here. If so either use "SKIP"
+# or replace with your tarball sha256sum
+
+# A user has reported that "--prefix=/usr" was needed with "./configure" such that IPopt could recognize the installation. That was not the case for me.
pkgname=coin-or-hsl
_pkgname=coinhsl
@@ -8,7 +13,7 @@ pkgver=2019.05.21
pkgdesc="HSL Mathematical Software Library. Including solvers for sparse linear systems of equations and sparse eigenvalue problems. Compiled with coin-or-tools, supports Ipopt."
arch=('i686' 'x86_64')
url="http://www.hsl.rl.ac.uk/"
-makedepends=('gcc' 'metis')
+makedepends=('gcc' 'metis' 'gcc-fortran')
depends=()
optdepends=('openmp' 'coin-or-ipopt')
source=("ThirdParty-HSL::git+https://github.com/coin-or-tools/ThirdParty-HSL.git" "manual://${_pkgname}-${pkgver}.tar.gz")
@@ -18,6 +23,7 @@ build() {
cd $srcdir/ThirdParty-HSL
ln -sf ../${_pkgname}-${pkgver} coinhsl
./configure
+ #./configure --prefix=/usr
make DESTDIR=$pkgdir
}