summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mugnai2022-01-03 11:45:39 +0100
committerMichael Mugnai2022-01-15 11:43:39 +0100
commite5220bd7eb8a201ceaf2b485c50106722f8a2a40 (patch)
tree2697d18cc7a73c59eaf54df179fbc9db0590981c
parent02392f690734217b76384b0c4f44a42c71bf8d05 (diff)
downloadaur-e5220bd7eb8a201ceaf2b485c50106722f8a2a40.tar.gz
update dependencies, optimise build, add gitignore
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD18
-rw-r--r--coinhsl-2019.05.21.tar.gz0
4 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0fabd53f091..0ba25dfd38b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = coin-or-hsl
makedepends = gcc
makedepends = metis
makedepends = gcc-fortran
+ depends = openblas-lapack
optdepends = openmp
optdepends = coin-or-ipopt
source = ThirdParty-HSL::git+https://github.com/coin-or-tools/ThirdParty-HSL.git
@@ -16,4 +17,3 @@ pkgbase = coin-or-hsl
sha256sums = 95ce1160f0b013151a3e25d40337775c760a8f3a79d801a1d190598bf4e4c0c3
pkgname = coin-or-hsl
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..15984106b2f7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# build artifacts
+*.zst
+pkg
+src
+
+# sources
+ThirdParty-HSL
+coinhsl-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index dea153cb0468..c41abc373302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,9 @@
# Maintainer: Samuel Balula sbalula@ethz.ch
# Intructions/ Troubleshoot
-# Download the source from http://www.hsl.rl.ac.uk/ and place it in the folder, replacing the empty placeholder file
+# Download the source from https://www.hsl.rl.ac.uk/ipopt/ and place it in the folder, replacing the empty placeholder file
# Check the sha256sum of the downloaded tarball, it may be different from the one listed here. If so either use "SKIP"
# or replace with your tarball sha256sum
-# A user has reported that "--prefix=/usr" was needed with "./configure" such that IPopt could recognize the installation. That was not the case for me.
-
pkgname=coin-or-hsl
_pkgname=coinhsl
pkgrel=1
@@ -14,7 +12,7 @@ pkgdesc="HSL Mathematical Software Library. Including solvers for sparse linear
arch=('i686' 'x86_64')
url="http://www.hsl.rl.ac.uk/"
makedepends=('gcc' 'metis' 'gcc-fortran')
-depends=()
+depends=('openblas-lapack')
optdepends=('openmp' 'coin-or-ipopt')
source=("ThirdParty-HSL::git+https://github.com/coin-or-tools/ThirdParty-HSL.git" "manual://${_pkgname}-${pkgver}.tar.gz")
sha256sums=("SKIP" "95ce1160f0b013151a3e25d40337775c760a8f3a79d801a1d190598bf4e4c0c3")
@@ -22,16 +20,14 @@ sha256sums=("SKIP" "95ce1160f0b013151a3e25d40337775c760a8f3a79d801a1d190598bf4e4
build() {
cd $srcdir/ThirdParty-HSL
ln -sf ../${_pkgname}-${pkgver} coinhsl
- ./configure
- #./configure --prefix=/usr
+ OMP_NUM_THREADS=$(nproc) ./configure --prefix=/usr LIBS="-llapack" --with-blas="-L/usr/lib -lopenblas" CXXFLAGS="-O3 -fopenmp" FCFLAGS="-O3 -fopenmp" CFLAGS="-O3 -fopenmp"
make DESTDIR=$pkgdir
}
-package ()
-{
+package () {
cd $srcdir/ThirdParty-HSL
make DESTDIR=$pkgdir install
- #For Ipopt:
- ln -rs $pkgdir/usr/local/lib/libcoinhsl.so $pkgdir/usr/local/lib/libhsl.so
-}
+ # For Ipopt:
+ ln -rs $pkgdir/usr/lib/libcoinhsl.so $pkgdir/usr/lib/libhsl.so
+}
diff --git a/coinhsl-2019.05.21.tar.gz b/coinhsl-2019.05.21.tar.gz
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/coinhsl-2019.05.21.tar.gz
+++ /dev/null