summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2021-04-13 17:47:11 +1000
committerLuis Aranguren2021-04-13 17:47:11 +1000
commitfbb0ae20253d82f76df9f1ccc1c81104c1cb0956 (patch)
treeb3fa40b3d7654b09411e9dd7d13f8ce24bd0d998
downloadaur-fbb0ae20253d82f76df9f1ccc1c81104c1cb0956.tar.gz
1.3.0-3 Renamed from coinomi-desktop, added gtk3 dependency
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--coinomi.pngbin0 -> 149192 bytes
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f97cf351b681
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = coinomi-wallet-bin
+ pkgdesc = Coinomi desktop wallet. Securely store, manage and exchange Bitcoin, Ethereum, and more than 500 other blockchain assets.
+ pkgver = 1.3.0
+ pkgrel = 3
+ url = https://coinomi.com
+ arch = x86_64
+ license = unknown
+ depends = java-runtime
+ depends = libxss
+ depends = gtk3
+ source = https://storage.coinomi.com/binaries/desktop/coinomi-wallet-1.3.0-linux64.tar.gz
+ source = coinomi.png
+ sha256sums = b914fb58a209721eabdd267aac74d0331a425189497320f6e3ac28c58634da36
+ sha256sums = 8b390909072edf85b195dbb73b5cceb52ae9f19093cce5ae313827590ae9d576
+
+pkgname = coinomi-wallet-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09190bcd1050
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: DeedleFake <deedlefake at users dot noreply dot github dot com>
+
+pkgname=coinomi-wallet-bin
+pkgver=1.3.0
+pkgrel=3
+pkgdesc="Coinomi desktop wallet. Securely store, manage and exchange Bitcoin, Ethereum, and more than 500 other blockchain assets."
+arch=(x86_64)
+url="https://coinomi.com"
+license=('unknown')
+depends=(java-runtime libxss gtk3)
+source=("https://storage.coinomi.com/binaries/desktop/coinomi-wallet-$pkgver-linux64.tar.gz"
+ "coinomi.png")
+sha256sums=('b914fb58a209721eabdd267aac74d0331a425189497320f6e3ac28c58634da36'
+ '8b390909072edf85b195dbb73b5cceb52ae9f19093cce5ae313827590ae9d576')
+#stupid server 502s if no user-agent
+DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
+
+build() {
+ chmod a+x "Coinomi/Coinomi"
+ sed -i 's/^Icon=.*$/Icon=coinomi/g' "Coinomi/coinomi-wallet.desktop"
+}
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ cp -r "$srcdir/Coinomi" "$pkgdir/opt/Coinomi/"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/Coinomi/Coinomi" "$pkgdir/usr/bin/Coinomi"
+ install -Dm644 "Coinomi/coinomi-wallet.desktop" "${pkgdir}/usr/share/applications/coinomi-wallet.desktop"
+ install -Dm644 "coinomi.png" "$pkgdir/usr/share/pixmaps/coinomi.png"
+}
diff --git a/coinomi.png b/coinomi.png
new file mode 100644
index 000000000000..8d34a09be85b
--- /dev/null
+++ b/coinomi.png
Binary files differ