summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2018-06-23 21:15:24 +1000
committerStephen Gregoratto2018-06-23 21:15:24 +1000
commit5bde20da82d5f5ed5a9320b65bd7a4d873e3b3fb (patch)
tree8366ccd55e0de4deff51931d6aa247740d56ea6b
parent71022524e0d7c6e8b95a8f475ee9678513f9423e (diff)
downloadaur-5bde20da82d5f5ed5a9320b65bd7a4d873e3b3fb.tar.gz
Replace wonky compilation with upstream binary
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 9 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c377c4341bf..c5d0c28c8d9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
pkgbase = cointop
pkgdesc = An interactive, real-time cryptocurrency monitor
pkgver = 1.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/miguelmota/cointop
arch = x86_64
- arch = i686
license = APACHE
- makedepends = go
- options = !strip
- options = !emptydirs
- source = https://github.com/miguelmota/cointop/archive/1.0.6.tar.gz
- sha256sums = 6188f21e7fcdfe686324a30a5ccc89a684e2a9acd81f2b042309ec0b28c26272
+ source = https://github.com/miguelmota/cointop/releases/download/1.0.6/cointop_1.0.6_linux_amd64.tar.gz
+ sha256sums = 6da759bf9ad67b167cdf28de8bd86779a57297318fc914ab5957f8f60361b83b
pkgname = cointop
diff --git a/PKGBUILD b/PKGBUILD
index d0544400df99..0553c134454f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,15 @@
pkgname=cointop
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="An interactive, real-time cryptocurrency monitor"
-arch=('x86_64' 'i686')
+arch=('x86_64')
url="https://github.com/miguelmota/cointop"
license=('APACHE')
-makedepends=('go')
-options=('!strip' '!emptydirs')
-source=("$url/archive/$pkgver.tar.gz")
-sha256sums=('6188f21e7fcdfe686324a30a5ccc89a684e2a9acd81f2b042309ec0b28c26272')
-
-prepare() {
- cd "$pkgname-$pkgver"
-
- GOPATH="$(pwd)" go get -d -v
-}
-
-build(){
- cd "$pkgname-$pkgver"
-
- GOPATH="$(pwd)" go build -ldflags "-s -w"
-}
+source=("$url/releases/download/$pkgver/"$pkgname"_"$pkgver"_linux_amd64.tar.gz")
+sha256sums=('6da759bf9ad67b167cdf28de8bd86779a57297318fc914ab5957f8f60361b83b')
package() {
- cd "$pkgname-$pkgver"
-
- install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}