summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2021-06-19 17:38:43 -0400
committerusrmusicman2021-06-19 17:38:43 -0400
commited84c49cd27400d7af047db4ae32b5df8e83a99c (patch)
tree6e65fa7f3a5a5a37d9ff53f7c53368b99fb1c16d
parent716977e5e72c39a8a663c762792fdf4841e005b4 (diff)
downloadaur-ed84c49cd27400d7af047db4ae32b5df8e83a99c.tar.gz
PKGBUILD
-rw-r--r--.SRCINFO6
-rwxr-xr-xCollaB3.desktop9
-rwxr-xr-x[-rw-r--r--]PKGBUILD19
3 files changed, 6 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0580d990fb4c..39d682e551db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = collab3
- pkgdesc = CollaB3 Tonewheel Organ (VST Plugin).
+ pkgdesc = CollaB3 Tonewheel Organ (VST Plugin)
pkgver = 1.0.0
pkgrel = 1
url = https://librewave.com/product/collab3/
@@ -8,10 +8,8 @@ pkgbase = collab3
groups = vst-plugins
license = GPL3
depends = libcurl-gnutls
+ depends = glibc
source = https://github.com/augustofilocamo/superOrgan/releases/download/v1.0.0/CollaB3-Installer-1.0.0.sh
- source = CollaB3.desktop
md5sums = 6f8e3d250f3287c81b30c11031b08c32
- md5sums = ef4fc82af3606b71d7a27a53289647b0
pkgname = collab3
-
diff --git a/CollaB3.desktop b/CollaB3.desktop
deleted file mode 100755
index 91584822ab14..000000000000
--- a/CollaB3.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=CollaB3
-Exec=CollaB3
-Terminal=false
-StartupNotify=true
-GenericName=Librewave CollaB3 Tonewheel Organ Plugin Standalone
-Categories=AudioVideo;Audio;
diff --git a/PKGBUILD b/PKGBUILD
index 1beaf5dc87df..368850a13927 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,14 @@
-# Maintainer Alexander Mcmillan <linuxguy93@gmail.com>
-
pkgname=collab3
pkgver=1.0.0
pkgrel=1
-pkgdesc="CollaB3 Tonewheel Organ (VST Plugin)."
+pkgdesc="CollaB3 Tonewheel Organ (VST Plugin)"
arch=('x86_64')
url="https://librewave.com/product/collab3/"
license=('GPL3')
groups=('pro-audio' 'vst-plugins')
-depends=('libcurl-gnutls')
-source=("https://github.com/augustofilocamo/superOrgan/releases/download/v${pkgver}/CollaB3-Installer-${pkgver}.sh"
- "CollaB3.desktop"
- )
-md5sums=('6f8e3d250f3287c81b30c11031b08c32'
- 'ef4fc82af3606b71d7a27a53289647b0')
+depends=('libcurl-gnutls' 'glibc')
+source=("https://github.com/augustofilocamo/superOrgan/releases/download/v${pkgver}/CollaB3-Installer-${pkgver}.sh")
+md5sums=('6f8e3d250f3287c81b30c11031b08c32')
prepare () {
## Extract CollaB3 Tonewheel Organ
@@ -22,12 +17,6 @@ prepare () {
}
package() {
- ## Install Standalone Application
- install -Dm755 "$srcdir/CollaB3" "$pkgdir/usr/bin/CollaB3"
-
- ## Install Desktop Launcher
- install -Dm644 "$srcdir/CollaB3.desktop" "$pkgdir/usr/share/applications/CollaB3.desktop"
-
## Install VST Plugin
install -Dm755 "$srcdir/CollaB3.so" "$pkgdir/usr/lib/vst/CollaB3.so"