summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZachary Koesters2016-05-12 15:27:29 -0500
committerZachary Koesters2016-05-12 15:27:29 -0500
commit637a31d5595bc8e4c3fc64ede56841cdeb0662ff (patch)
treef695ae4328deb5da1ce330be4f1c32bc68ff42b1
parent6e4d1f21f91fa5c38782455ffbb72c0dbddc1712 (diff)
downloadaur-637a31d5595bc8e4c3fc64ede56841cdeb0662ff.tar.gz
Added patch fixing GCC 6 error
-rw-r--r--.SRCINFO4
-rw-r--r--0001-fix-return-type-thanks-to-22.patch25
-rw-r--r--PKGBUILD18
3 files changed, 42 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef436ecb95cb..e27500b99eb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jan 29 17:37:30 UTC 2016
+# Thu May 12 20:26:52 UTC 2016
pkgbase = collada-dom
pkgdesc = An API that provides a C++ object representation of a COLLADA XML instance document.
pkgver = 2.4.4
@@ -14,7 +14,9 @@ pkgbase = collada-dom
depends = pcre
provides = colladadom
source = https://github.com/rdiankov/collada-dom/archive/v2.4.4.tar.gz
+ source = 0001-fix-return-type-thanks-to-22.patch
sha256sums = 0dfa494827faa971310c871535b319cadbd0c2d6958ee11b303c61a55a5a437a
+ sha256sums = 921742c7ad1094e1f25281869860b16cbab9d1fb0cb718fb32e0775861bdb13c
pkgname = collada-dom
diff --git a/0001-fix-return-type-thanks-to-22.patch b/0001-fix-return-type-thanks-to-22.patch
new file mode 100644
index 000000000000..eb3b944e24b1
--- /dev/null
+++ b/0001-fix-return-type-thanks-to-22.patch
@@ -0,0 +1,25 @@
+From 8e65676c1cbecde1c0c4d8c2e1cfb20fc49c410b Mon Sep 17 00:00:00 2001
+From: rosen <rosen.diankov@mujin.co.jp>
+Date: Wed, 24 Feb 2016 12:49:14 +0900
+Subject: [PATCH] fix return type thanks to #22
+
+---
+ dom/src/dae/daeMetaGroup.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dom/src/dae/daeMetaGroup.cpp b/dom/src/dae/daeMetaGroup.cpp
+index 25fd9cc..c34ac4c 100644
+--- a/dom/src/dae/daeMetaGroup.cpp
++++ b/dom/src/dae/daeMetaGroup.cpp
+@@ -26,7 +26,7 @@ daeElement *daeMetaGroup::placeElement( daeElement *parent, daeElement *child, d
+ (void)offset;
+ daeString nm = child->getElementName();
+ if ( findChild( nm ) == NULL ) {
+- return false;
++ return NULL;
+ }
+ daeElementRef el;
+
+--
+2.8.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 706795dd8bb6..1d91e74f4aae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,20 @@ pkgdesc="An API that provides a C++ object representation of a COLLADA XML insta
url="https://github.com/rdiankov/collada-dom/tree/v2.4.4"
license=("custom")
arch=("any")
-depends=("libxml2" "boost-libs" "pcre")
-makedepends=("cmake" "boost")
-source=("https://github.com/rdiankov/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=("0dfa494827faa971310c871535b319cadbd0c2d6958ee11b303c61a55a5a437a")
+depends=("libxml2"
+ "boost-libs"
+ "pcre")
+makedepends=("cmake"
+ "boost")
+source=("https://github.com/rdiankov/${pkgname}/archive/v${pkgver}.tar.gz"
+ "0001-fix-return-type-thanks-to-22.patch")
+sha256sums=("0dfa494827faa971310c871535b319cadbd0c2d6958ee11b303c61a55a5a437a"
+ "921742c7ad1094e1f25281869860b16cbab9d1fb0cb718fb32e0775861bdb13c")
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 < ../0001-fix-return-type-thanks-to-22.patch
+}
build() {
cd "${pkgname}-${pkgver}"