summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:06:40 +0000
committerAntonio Rojas2021-05-08 09:06:40 +0000
commit2bc54f240eb65d9abe91ea9ab75c35741fc3bebc (patch)
tree038736fb0a8ea922f38b2c96fa764c5ac79a343e
downloadaur-2bc54f240eb65d9abe91ea9ab75c35741fc3bebc.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO74
-rw-r--r--PKGBUILD72
-rw-r--r--service13
3 files changed, 159 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4175083f7159
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,74 @@
+pkgbase = collectd
+ pkgdesc = Daemon which collects system performance statistics periodically
+ pkgver = 5.12.0
+ pkgrel = 3
+ url = https://collectd.org/
+ arch = x86_64
+ license = GPL
+ makedepends = curl
+ makedepends = libdbi
+ makedepends = libesmtp
+ makedepends = libgcrypt
+ makedepends = libmemcached
+ makedepends = mariadb-libs
+ makedepends = systemd-libs
+ makedepends = iproute2
+ makedepends = net-snmp
+ makedepends = libnotify
+ makedepends = openipmi
+ makedepends = liboping
+ makedepends = libpcap
+ makedepends = perl
+ makedepends = postgresql-libs
+ makedepends = python
+ makedepends = rrdtool
+ makedepends = lm_sensors
+ makedepends = libvirt
+ makedepends = libxml2
+ makedepends = yajl
+ makedepends = libatasmart
+ makedepends = lvm2
+ makedepends = protobuf-c
+ makedepends = mosquitto
+ makedepends = libmicrohttpd
+ makedepends = librabbitmq-c
+ makedepends = nut
+ depends = libltdl
+ depends = iptables
+ depends = libnsl
+ optdepends = curl: apache, ascent, curl, nginx, and write_http plugins
+ optdepends = libdbi: dbi plugin
+ optdepends = libesmtp: notify_email plugin
+ optdepends = libgcrypt: encryption and authentication for network plugin
+ optdepends = libmemcached: memcachec plugin
+ optdepends = mariadb-libs: mysql plugin
+ optdepends = systemd-libs: UdevNameAttr option
+ optdepends = iproute2: netlink plugin
+ optdepends = net-snmp: snmp plugin
+ optdepends = libnotify: notify_desktop plugin
+ optdepends = openipmi: ipmi plugin
+ optdepends = liboping: ping plugin
+ optdepends = libpcap: dns plugin
+ optdepends = perl: perl plugin
+ optdepends = postgresql-libs: postgresql plugin
+ optdepends = python: python plugin
+ optdepends = rrdtool: rrdtool and rrdcached plugins
+ optdepends = lm_sensors: lm_sensors and sensors plugins
+ optdepends = libvirt: libvirt plugin
+ optdepends = libxml2: ascent and libvirt plugins
+ optdepends = yajl: curl_json plugin
+ optdepends = libatasmart: smart plugin
+ optdepends = lvm2: lvm plugin
+ optdepends = protobuf-c: write_riemann plugin
+ optdepends = mosquitto: MQTT plugin
+ optdepends = libmicrohttpd: prometheus plugin
+ optdepends = librabbitmq-c: amqp plugin
+ optdepends = nut: nut plugin
+ backup = etc/collectd.conf
+ source = https://storage.googleapis.com/collectd-tarballs/collectd-5.12.0.tar.bz2
+ source = service
+ sha256sums = 5bae043042c19c31f77eb8464e56a01a5454e0b39fa07cf7ad0f1bfc9c3a09d6
+ sha256sums = e45e261146563b0bf6967c669dff7ac2400f066f0eb4c022ac3fdb0ccadca2f9
+
+pkgname = collectd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ef093a54a21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer:
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Gerhard Brauer <gerhard.brauer@web.de>
+
+pkgname=collectd
+pkgver=5.12.0
+pkgrel=3
+pkgdesc='Daemon which collects system performance statistics periodically'
+url='https://collectd.org/'
+arch=('x86_64')
+license=('GPL')
+
+optdepends=('curl: apache, ascent, curl, nginx, and write_http plugins'
+ 'libdbi: dbi plugin'
+ 'libesmtp: notify_email plugin'
+ 'libgcrypt: encryption and authentication for network plugin'
+ 'libmemcached: memcachec plugin'
+ 'mariadb-libs: mysql plugin'
+ 'systemd-libs: UdevNameAttr option'
+ 'iproute2: netlink plugin'
+ 'net-snmp: snmp plugin'
+ 'libnotify: notify_desktop plugin'
+ 'openipmi: ipmi plugin'
+ 'liboping: ping plugin'
+ 'libpcap: dns plugin'
+ 'perl: perl plugin'
+ 'postgresql-libs: postgresql plugin'
+ 'python: python plugin'
+ 'rrdtool: rrdtool and rrdcached plugins'
+ 'lm_sensors: lm_sensors and sensors plugins'
+ 'libvirt: libvirt plugin'
+ 'libxml2: ascent and libvirt plugins'
+ 'yajl: curl_json plugin'
+ 'libatasmart: smart plugin'
+ 'lvm2: lvm plugin'
+ 'protobuf-c: write_riemann plugin'
+ 'mosquitto: MQTT plugin'
+ 'libmicrohttpd: prometheus plugin'
+ 'librabbitmq-c: amqp plugin'
+ 'nut: nut plugin')
+
+makedepends=(${optdepends[@]%:*})
+depends=('libltdl' 'iptables' 'libnsl')
+
+source=("https://storage.googleapis.com/collectd-tarballs/${pkgname}-${pkgver}.tar.bz2"
+ 'service')
+sha256sums=('5bae043042c19c31f77eb8464e56a01a5454e0b39fa07cf7ad0f1bfc9c3a09d6'
+ 'e45e261146563b0bf6967c669dff7ac2400f066f0eb4c022ac3fdb0ccadca2f9')
+
+backup=('etc/collectd.conf')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --disable-werror \
+ --with-python=/usr/bin/python \
+ --with-perl-bindings='INSTALLDIRS=vendor' \
+
+ make all
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ rmdir "${pkgdir}/var/run" # FS#30201
+ install -Dm644 ../service "${pkgdir}"/usr/lib/systemd/system/collectd.service
+ install -Dm644 contrib/collectd2html.pl "${pkgdir}"/usr/share/collectd/collectd2html.pl
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..30540645a604
--- /dev/null
+++ b/service
@@ -0,0 +1,13 @@
+[Unit]
+Description=System statistics collection daemon
+After=local-fs.target network.target
+
+[Service]
+Type=forking
+PIDFile=/run/collectdmon.pid
+ExecStart=/usr/bin/collectdmon
+ExecReload=/bin/kill -HUP $MAINPID
+Restart=always
+
+[Install]
+WantedBy=multi-user.target