summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author依云2023-05-07 15:14:25 +0800
committerlilac2023-05-07 15:15:57 +0800
commit694bf56810f20c9077fc0b290aa37fb86beae827 (patch)
treed19b58c97b2894ced5f41013d990ec331aabe4b0
parentaa1a0a703dc92263c232f4214770d9a11226c024 (diff)
downloadaur-694bf56810f20c9077fc0b290aa37fb86beae827.tar.gz
fix for Python 3.11
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e449dce178f..a1e929e1f2a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = collectd
pkgdesc = Daemon which collects system performance statistics periodically
pkgver = 5.12.0
- pkgrel = 9
+ pkgrel = 11
url = https://collectd.org/
arch = x86_64
arch = aarch64
@@ -68,7 +68,9 @@ pkgbase = collectd
backup = etc/collectd.conf
source = https://storage.googleapis.com/collectd-tarballs/collectd-5.12.0.tar.bz2
source = service
+ source = https://github.com/collectd/collectd/commit/623e95394e0e62e7f9ced2104b786d21e9c0bf53.patch
sha256sums = 5bae043042c19c31f77eb8464e56a01a5454e0b39fa07cf7ad0f1bfc9c3a09d6
sha256sums = 83957b0b2cc7fa05a4d5f22e6c913ae2b0a4d7821f7b4e2d2e763054cc8c6c21
+ sha256sums = 777544cbf803af4d08ea228b29619f8f6e7a4777a85e0fb30693d8240db7246b
pkgname = collectd
diff --git a/PKGBUILD b/PKGBUILD
index 0e1e2c7eaddd..c60d18b85253 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=collectd
pkgver=5.12.0
-pkgrel=9
+pkgrel=11
pkgdesc='Daemon which collects system performance statistics periodically'
url='https://collectd.org/'
arch=('x86_64' 'aarch64')
@@ -43,15 +43,18 @@ makedepends=(${optdepends[@]%:*})
depends=('libltdl' 'iptables' 'libnsl')
source=("https://storage.googleapis.com/collectd-tarballs/${pkgname}-${pkgver}.tar.bz2"
- 'service')
+ 'service'
+ 'https://github.com/collectd/collectd/commit/623e95394e0e62e7f9ced2104b786d21e9c0bf53.patch')
sha256sums=('5bae043042c19c31f77eb8464e56a01a5454e0b39fa07cf7ad0f1bfc9c3a09d6'
- '83957b0b2cc7fa05a4d5f22e6c913ae2b0a4d7821f7b4e2d2e763054cc8c6c21')
+ '83957b0b2cc7fa05a4d5f22e6c913ae2b0a4d7821f7b4e2d2e763054cc8c6c21'
+ '777544cbf803af4d08ea228b29619f8f6e7a4777a85e0fb30693d8240db7246b')
backup=('etc/collectd.conf')
prepare() {
cd ${pkgname}-${pkgver}
sed -i '/sys\/mount.h/d' src/utils/mount/mount.h
+ patch -Np1 < ../623e95394e0e62e7f9ced2104b786d21e9c0bf53.patch
}
build() {
@@ -62,7 +65,6 @@ build() {
--localstatedir=/var \
--sbindir=/usr/bin \
--disable-werror \
- --with-python=/usr/bin/python \
--with-perl-bindings='INSTALLDIRS=vendor' \
make all