summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author依云2022-08-28 16:06:58 +0800
committer依云2022-08-28 16:06:58 +0800
commitcfb6cf7f2605baa16733b5c834627ea8e962b782 (patch)
treeca4b0dcd468d281478b55f4d68eba10d637e54ba
parent7b80fdf4e64d6fb34f5b4bac1edf0f5ef287238f (diff)
downloadaur-cfb6cf7f2605baa16733b5c834627ea8e962b782.tar.gz
fix build issues with glibc 2.36
see https://github.com/collectd/collectd/issues/4034
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2aeee0b209fd..0e1e2c7eaddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
pkgname=collectd
pkgver=5.12.0
-pkgrel=6
+pkgrel=9
pkgdesc='Daemon which collects system performance statistics periodically'
url='https://collectd.org/'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
license=('GPL')
optdepends=('curl: apache, ascent, curl, nginx, and write_http plugins'
@@ -49,6 +49,11 @@ sha256sums=('5bae043042c19c31f77eb8464e56a01a5454e0b39fa07cf7ad0f1bfc9c3a09d6'
backup=('etc/collectd.conf')
+prepare() {
+ cd ${pkgname}-${pkgver}
+ sed -i '/sys\/mount.h/d' src/utils/mount/mount.h
+}
+
build() {
cd ${pkgname}-${pkgver}
./configure \