summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Angelopoulos2015-12-28 02:48:04 +0100
committerGeorge Angelopoulos2015-12-28 02:48:04 +0100
commit1ccfc26fd8aa70dbbc73173593eb25b10701102c (patch)
tree0e0bef23cb079322d5d73f00865389daceba2da9
parenteded2ad0870936944eccd272ef3df8885824b4e7 (diff)
downloadaur-1ccfc26fd8aa70dbbc73173593eb25b10701102c.tar.gz
add systemd service
I put this together quickly and it doesn't exist in upstream.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--collectl.service10
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 483e120de91b..e4f52b68fd28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Dec 26 12:22:32 UTC 2015
+# Mon Dec 28 01:47:06 UTC 2015
pkgbase = collectl
pkgdesc = A tool for viewing and gethering system performance metrics.
pkgver = 4.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://collectl.sourceforge.net/
arch = any
license = GPL2
@@ -11,7 +11,9 @@ pkgbase = collectl
depends = perl
backup = etc/collectl.conf
source = http://sourceforge.net/projects/collectl/files/collectl/collectl-4.0.2/collectl-4.0.2.src.tar.gz
+ source = collectl.service
md5sums = 8502fbb30539e6f9ac962b8577a863b4
+ md5sums = 5a8892732fb5a7d64c7071394024eff8
pkgname = collectl
diff --git a/PKGBUILD b/PKGBUILD
index cb4fe5e4b8ce..0a7ea4c79072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,17 @@
pkgname=collectl
pkgver=4.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for viewing and gethering system performance metrics."
arch=('any')
url="http://collectl.sourceforge.net/"
license=('GPL2' 'custom:artistic')
depends=('perl')
backup=('etc/collectl.conf')
-source=("http://sourceforge.net/projects/collectl/files/collectl/${pkgname}-${pkgver}/${pkgname}-${pkgver}.src.tar.gz")
-md5sums=('8502fbb30539e6f9ac962b8577a863b4')
+source=("http://sourceforge.net/projects/collectl/files/collectl/${pkgname}-${pkgver}/${pkgname}-${pkgver}.src.tar.gz"
+ "collectl.service")
+md5sums=('8502fbb30539e6f9ac962b8577a863b4'
+ '5a8892732fb5a7d64c7071394024eff8')
package() {
cd "${pkgname}-${pkgver}"
@@ -29,4 +31,5 @@ package() {
# match with any of the common ones in Arch Linux, we'll copy the
# artistic license here as custom.
install -D -m644 ARTISTIC "${pkgdir}/usr/share/licenses/${pkgname}/ARTISTIC"
+ install -D -m644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
}
diff --git a/collectl.service b/collectl.service
new file mode 100644
index 000000000000..a2bd7157d0f6
--- /dev/null
+++ b/collectl.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=collectl metric collection
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/collectl -D
+ExecReload=/bin/kill -USR1 $MAINPID
+
+[Install]
+WantedBy=multi-user.target