summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Angelopoulos2015-12-26 13:24:46 +0100
committerGeorge Angelopoulos2015-12-26 13:24:46 +0100
commiteded2ad0870936944eccd272ef3df8885824b4e7 (patch)
tree134df54b01628b96843c84d7cbb5ae916974c3a0
downloadaur-eded2ad0870936944eccd272ef3df8885824b4e7.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..483e120de91b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Dec 26 12:22:32 UTC 2015
+pkgbase = collectl
+ pkgdesc = A tool for viewing and gethering system performance metrics.
+ pkgver = 4.0.2
+ pkgrel = 1
+ url = http://collectl.sourceforge.net/
+ arch = any
+ license = GPL2
+ license = custom:artistic
+ depends = perl
+ backup = etc/collectl.conf
+ source = http://sourceforge.net/projects/collectl/files/collectl/collectl-4.0.2/collectl-4.0.2.src.tar.gz
+ md5sums = 8502fbb30539e6f9ac962b8577a863b4
+
+pkgname = collectl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..958d903ae63b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.src.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb4fe5e4b8ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: George Angelopoulos <george@usermod.net>
+
+# Upstream collectl provides an init script for running collectl as a service.
+# Since we have systemd instead, this needs to be fixed. Currently this package
+# doesn't provide a systemd unit for collectl.
+
+pkgname=collectl
+pkgver=4.0.2
+pkgrel=1
+pkgdesc="A tool for viewing and gethering system performance metrics."
+arch=('any')
+url="http://collectl.sourceforge.net/"
+license=('GPL2' 'custom:artistic')
+depends=('perl')
+backup=('etc/collectl.conf')
+source=("http://sourceforge.net/projects/collectl/files/collectl/${pkgname}-${pkgver}/${pkgname}-${pkgver}.src.tar.gz")
+md5sums=('8502fbb30539e6f9ac962b8577a863b4')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" ./INSTALL
+
+ # we don't have sysv init in arch
+ rm -rf ${pkgdir}/etc/init.d
+ rm -rf ${pkgdir}/usr/share/${pkgname}/UNINSTALL
+
+ # collectl is licensed under the GPL2 and some version of the ARTISTIC
+ # license. Since the version of the license from upstream doesn't
+ # match with any of the common ones in Arch Linux, we'll copy the
+ # artistic license here as custom.
+ install -D -m644 ARTISTIC "${pkgdir}/usr/share/licenses/${pkgname}/ARTISTIC"
+}