summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-07-18 08:12:53 -0600
committerMark Wagie2022-07-18 08:12:53 -0600
commit192517b62839af7534b5d6ff5951bf886357aa45 (patch)
tree153837c6ca76d0135d90f26600ad284848a85995
parent06676c9635b90ecacfaf43fde9be1716c6e7221e (diff)
downloadaur-192517b62839af7534b5d6ff5951bf886357aa45.tar.gz
add Dracula version, include Firefox theme
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
-rw-r--r--colloid-gtk-theme.install10
4 files changed, 23 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b123dfa5e7bf..4e4614ed8189 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = colloid-gtk-theme-git
pkgdesc = Modern and clean Gtk theme for linux
- pkgver = 2022.05.15.r2.g65f141f2
+ pkgver = 2022.07.18.r4.g947f142e
pkgrel = 1
url = https://www.pling.com/p/1661959
+ install = colloid-gtk-theme.install
arch = any
license = GPL3
makedepends = git
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..1bb3bcc4cded 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!colloid-gtk-theme.install
diff --git a/PKGBUILD b/PKGBUILD
index 7e6f0d2610e3..ad948a6e9018 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=colloid-gtk-theme-git
-pkgver=2022.05.15.r2.g65f141f2
+pkgver=2022.07.18.r4.g947f142e
pkgrel=1
pkgdesc="Modern and clean Gtk theme for linux"
arch=('any')
@@ -13,6 +13,7 @@ optdepends=('gtk-engine-murrine: GTK2 theme support'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
options=('!strip')
+install="${pkgname%-git}.install"
source=('git+https://github.com/vinceliuice/Colloid-gtk-theme.git')
sha256sums=('SKIP')
@@ -30,4 +31,12 @@ package() {
# Nord version
./install.sh -t all --tweaks nord -d "$pkgdir/usr/share/themes"
./install.sh -t all -s compact --tweaks nord -d "$pkgdir/usr/share/themes"
+
+ # Dracula version
+ ./install.sh -t all --tweaks dracula -d "$pkgdir/usr/share/themes"
+ ./install.sh -t all -s compact --tweaks dracula -d "$pkgdir/usr/share/themes"
+
+ # Firefox theme
+ install -d "$pkgdir/usr/share/doc/${pkgname%-git}"
+ cp -r src/other/firefox "$pkgdir/usr/share/doc/${pkgname%-git}/"
}
diff --git a/colloid-gtk-theme.install b/colloid-gtk-theme.install
new file mode 100644
index 000000000000..efd604a70a7c
--- /dev/null
+++ b/colloid-gtk-theme.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo ""
+ echo "Install Firefox theme - copy or symlink from /usr/share/doc/colloid-gtk-theme/firefox/:"
+ echo "https://github.com/vinceliuice/Colloid-gtk-theme/tree/main/src/other/firefox#installation"
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}