summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-04-05 18:42:38 -0600
committerMark Wagie2024-04-05 18:42:38 -0600
commitef6af703559fdf59f8b5ff5ec99682d820d31702 (patch)
tree1afd6741b90a2cdd89441379a43f1689ce592efe
parente1c622ece1cdab8f81036d8ef120c8d7ed1c38f3 (diff)
downloadaur-ef6af703559fdf59f8b5ff5ec99682d820d31702.tar.gz
split theme into default, dracula & nord
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
2 files changed, 35 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7269b9c8f332..9850ff73b5a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colloid-gtk-theme-git
- pkgdesc = Modern and clean Gtk theme for linux
- pkgver = 2023.10.28.r0.g46fa7423
+ pkgdesc = Gtk theme for Linux
+ pkgver = 2023.10.28.r7.g06da74bb
pkgrel = 1
url = https://github.com/vinceliuice/Colloid-gtk-theme
install = colloid-gtk-theme.install
@@ -18,3 +18,9 @@ pkgbase = colloid-gtk-theme-git
sha256sums = SKIP
pkgname = colloid-gtk-theme-git
+
+pkgname = colloid-dracula-gtk-theme-git
+ pkgdesc = Gtk Dracula theme for Linux
+
+pkgname = colloid-nord-gtk-theme-git
+ pkgdesc = Gtk Nord theme for Linux
diff --git a/PKGBUILD b/PKGBUILD
index fc6652e29d37..a6471bae9414 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
-pkgname=colloid-gtk-theme-git
-pkgver=2023.10.28.r0.g46fa7423
+pkgname=(
+ 'colloid-gtk-theme-git'
+ 'colloid-dracula-gtk-theme-git'
+ 'colloid-nord-gtk-theme-git'
+)
+pkgbase=colloid-gtk-theme-git
+pkgver=2023.10.28.r7.g06da74bb
pkgrel=1
-pkgdesc="Modern and clean Gtk theme for linux"
+pkgdesc="Gtk theme for Linux"
arch=('any')
url="https://github.com/vinceliuice/Colloid-gtk-theme"
license=('GPL-3.0-or-later')
@@ -22,17 +27,31 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
+package_colloid-gtk-theme-git() {
cd Colloid-gtk-theme
install -d "$pkgdir/usr/share/themes"
./install.sh -t all -d "$pkgdir/usr/share/themes"
./install.sh -t all -s compact --tweaks normal -d "$pkgdir/usr/share/themes"
- # Nord, Dracula & Gruvbox versions
- ./install.sh -t all --tweaks all -d "$pkgdir/usr/share/themes"
- ./install.sh -t all -s compact --tweaks all -d "$pkgdir/usr/share/themes"
-
# Firefox theme
install -d "$pkgdir/usr/share/doc/${pkgname%-git}"
cp -r src/other/firefox "$pkgdir/usr/share/doc/${pkgname%-git}/"
}
+
+package_colloid-dracula-gtk-theme-git() {
+ pkgdesc="Gtk Dracula theme for Linux"
+
+ cd Colloid-gtk-theme
+ install -d "$pkgdir/usr/share/themes"
+ ./install.sh -t all --tweaks dracula -d "$pkgdir/usr/share/themes"
+ ./install.sh -t all -s compact --tweaks dracula normal -d "$pkgdir/usr/share/themes"
+}
+
+package_colloid-nord-gtk-theme-git() {
+ pkgdesc="Gtk Nord theme for Linux"
+
+ cd Colloid-gtk-theme
+ install -d "$pkgdir/usr/share/themes"
+ ./install.sh -t all --tweaks nord -d "$pkgdir/usr/share/themes"
+ ./install.sh -t all -s compact --tweaks nord normal -d "$pkgdir/usr/share/themes"
+}