summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-06-22 13:17:06 +0200
committerbartus2019-06-22 13:17:06 +0200
commit0fec4a1e1396150f46c7d6f59775d0db74ba4275 (patch)
tree368d1a23c6653992a9e572064bb2ad181a57d393
parent16bbae33e8ce8b432cac5b9722505fcfe05fd46d (diff)
downloadaur-0fec4a1e1396150f46c7d6f59775d0db74ba4275.tar.gz
fix gcc9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--gcc9.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c09c06f93f30..0e6efbe139ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
pkgver = 3.6.dev.2.r13.g6af3d8b
- pkgrel = 1
+ pkgrel = 2
url = https://colmap.github.io/
install = colmap-git.install
arch = i686
@@ -25,12 +25,14 @@ pkgbase = colmap-git
optdepends = cuda-toolkit: for cuda sfm/mvs acceleration
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
+ source = gcc9.patch
source = colmap-git.install
source = vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin
md5sums = SKIP
md5sums = 1542bbbaa7951dbf0b2472354b4b493d
+ md5sums = cff4ef88ae7e4cb0d08265f9e6715364
md5sums = ebb1dc43e014a1e720a06422c6248a40
md5sums = 65b200a06e15205bda713c8553953c50
md5sums = 57e1c8073d9085631911e060c3802bd2
diff --git a/PKGBUILD b/PKGBUILD
index 8e792bd3c1e5..82ee699ff401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ name=colmap
fragment="#branch=dev"
pkgname=${name}-git
pkgver=3.6.dev.2.r13.g6af3d8b
-pkgrel=1
+pkgrel=2
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
url="https://colmap.github.io/"
@@ -22,6 +22,7 @@ fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"nvm-export.patch"
+ "gcc9.patch"
"${pkgname}.install"
"vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin"
"vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin"
@@ -29,6 +30,7 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
)
md5sums=('SKIP'
'1542bbbaa7951dbf0b2472354b4b493d'
+ 'cff4ef88ae7e4cb0d08265f9e6715364'
'ebb1dc43e014a1e720a06422c6248a40'
'65b200a06e15205bda713c8553953c50'
'57e1c8073d9085631911e060c3802bd2'
@@ -41,7 +43,7 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
- git apply ${srcdir}/nvm-export.patch
+ git apply ${srcdir}/*.patch
}
diff --git a/gcc9.patch b/gcc9.patch
new file mode 100644
index 000000000000..a0ce611521a8
--- /dev/null
+++ b/gcc9.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/VLFeat/kmeans.c b/lib/VLFeat/kmeans.c
+index c250ca8..4887fc4 100755
+--- a/lib/VLFeat/kmeans.c
++++ b/lib/VLFeat/kmeans.c
+@@ -669,7 +669,7 @@ VL_XCAT(_vl_kmeans_quantize_, SFX)
+ #endif
+
+ #ifdef _OPENMP
+-#pragma omp parallel \
++#pragma omp parallel firstprivate(vl_infinity_d) \
+ shared(self, distances, assignments, numData, distFn, data) \
+ num_threads(vl_get_max_threads())
+ #endif