summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-05-25 11:52:35 +0200
committerbartus2018-05-25 11:52:35 +0200
commit2859fcde493eb616ebce060d8aff9139622dc925 (patch)
treef138747d6731c4c41cbdd59762e0b67d1ac9f1ef
parent6b28a316f5553c09f8fc0690e2ed1bb6b8523045 (diff)
downloadaur-2859fcde493e.tar.gz
relax deps to allow other cuda version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c91961f9949..e64140b662ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.4.r68.g3803109
+ pkgver = 3.4.r80.g36db96a
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -12,7 +12,7 @@ pkgbase = colmap-git
makedepends = git
makedepends = cmake
makedepends = eigen
- makedepends = cuda
+ makedepends = cuda-sdk
depends = gflags
depends = suitesparse
depends = freeglut
@@ -21,7 +21,7 @@ pkgbase = colmap-git
depends = freeimage
depends = boost-libs
depends = qt5-base
- optdepends = cuda: for cuda sfm/mvs acceleration
+ optdepends = cuda-toolkit: for cuda sfm/mvs acceleration
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
source = colmap-git.install
diff --git a/PKGBUILD b/PKGBUILD
index a40486490e5b..596710c46550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
-
####to disable cuda kernel comment out this line
_BUILD_CUDA="on"
@@ -7,7 +6,7 @@ name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.4.r68.g3803109
+pkgver=3.4.r80.g36db96a
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
@@ -17,8 +16,8 @@ groups=()
depends=('gflags' 'suitesparse' 'freeglut' 'glew' 'google-glog' 'freeimage' 'boost-libs' 'qt5-base')
makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen' )
if [ "$_BUILD_CUDA" == "on" ] ; then
- makedepends+=('cuda')
- optdepends=('cuda: for cuda sfm/mvs acceleration')
+ makedepends+=('cuda-sdk')
+ optdepends=('cuda-toolkit: for cuda sfm/mvs acceleration')
fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
@@ -53,7 +52,7 @@ build() {
export CXXFLAGS=${CFLAGS/-fno-plt/}
# determine whether we can precompile CUDA kernels
- _CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
+ _CUDA_PKG=`pacman -Qsq cuda 2>/dev/null` || true
if [ -n "$_CUDA_PKG" -a "$_BUILD_CUDA"=="on" ]; then
_EXTRAOPTS="-DCUDA_ENABLED=ON -DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc -DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda"
else