summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-06-28 15:10:20 +0200
committerbartus2017-06-28 15:10:20 +0200
commit70bfdbdb7956eb446c3d3a6505e04ae474bc0453 (patch)
treefe81bfed0fcce81dae7712bb99be10e7bbb30a8f
parentc8627480fba8335637f6791e154c436bcf7a3628 (diff)
downloadaur-70bfdbdb7956eb446c3d3a6505e04ae474bc0453.tar.gz
gcc7 fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--nvm-export.patch46
3 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52a944feb07c..8d0999f3a41c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 2.1.r145.g2789ca2
+ pkgver = 3.1.r20.gb1af506
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -12,7 +12,7 @@ pkgbase = colmap-git
makedepends = git
makedepends = cmake
makedepends = eigen
- depends = lapack
+ depends = gflags
depends = suitesparse
depends = freeglut
depends = glew
@@ -29,7 +29,7 @@ pkgbase = colmap-git
source = vocabulary-tree-256K.bin::http://cvg.ethz.ch/research/jschoenb/colmap/vocab_tree-262144.bin
source = vocabulary-tree-1M.bin::http://cvg.ethz.ch/research/jschoenb/colmap/vocab_tree-1048576.bin
md5sums = SKIP
- md5sums = a59344b125e438a446f4ae1e747ea150
+ md5sums = 8a9f76c21ae93e5f5571f372f5401423
md5sums = ebb1dc43e014a1e720a06422c6248a40
md5sums = 55d81534d969cf706719007462f20443
md5sums = 3521ff3c601596473c6ce5256772f606
diff --git a/PKGBUILD b/PKGBUILD
index 7c77cc769715..8e36a9c41c54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
name=colmap
pkgname=${name}-git
-pkgver=2.1.r145.g2789ca2
+pkgver=3.1.r20.gb1af506
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
url="https://colmap.github.io/"
license=('GPL')
groups=()
-depends=('lapack' 'suitesparse' 'freeglut' 'glew' 'google-glog' 'freeimage' 'boost-libs' 'qt5-base')
+depends=('gflags' 'suitesparse' 'freeglut' 'glew' 'google-glog' 'freeimage' 'boost-libs' 'qt5-base')
makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen')
optdepends=('cuda: for cuda sfm/mvs acceleration')
provides=()
@@ -23,7 +23,7 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git"
"vocabulary-tree-1M.bin::http://cvg.ethz.ch/research/jschoenb/colmap/vocab_tree-1048576.bin"
)
md5sums=('SKIP'
- 'a59344b125e438a446f4ae1e747ea150'
+ '8a9f76c21ae93e5f5571f372f5401423'
'ebb1dc43e014a1e720a06422c6248a40'
'55d81534d969cf706719007462f20443'
'3521ff3c601596473c6ce5256772f606'
diff --git a/nvm-export.patch b/nvm-export.patch
index eeecbf60deb1..a0c995c04900 100644
--- a/nvm-export.patch
+++ b/nvm-export.patch
@@ -1,17 +1,17 @@
diff --git a/src/base/reconstruction.cc b/src/base/reconstruction.cc
-index 87c96a0..efa65a6 100755
+index 5674363..794b994 100755
--- a/src/base/reconstruction.cc
+++ b/src/base/reconstruction.cc
-@@ -1033,7 +1033,7 @@ void Reconstruction::ImportPLY(const std::string& path) {
+@@ -952,7 +952,7 @@ void Reconstruction::ImportPLY(const std::string& path) {
}
}
-bool Reconstruction::ExportNVM(const std::string& path) const {
+bool Reconstruction::ExportNVM(const std::string& path, const std::string& image_path) const {
- std::ofstream file(path.c_str(), std::ios::trunc);
- CHECK(file.is_open());
+ std::ofstream file(path, std::ios::trunc);
+ CHECK(file.is_open()) << path;
-@@ -1060,7 +1060,13 @@ bool Reconstruction::ExportNVM(const std::string& path) const {
+@@ -979,7 +979,13 @@ bool Reconstruction::ExportNVM(const std::string& path) const {
-1 * camera.Params(SimpleRadialCameraModel::extra_params_idxs[0]);
const Eigen::Vector3d proj_center = image.ProjectionCenter();
@@ -27,10 +27,10 @@ index 87c96a0..efa65a6 100755
file << image.Qvec(0) << " ";
file << image.Qvec(1) << " ";
diff --git a/src/base/reconstruction.h b/src/base/reconstruction.h
-index 4118509..3fd7e0b 100755
+index 7cb5ffb..c2b1d84 100755
--- a/src/base/reconstruction.h
+++ b/src/base/reconstruction.h
-@@ -230,7 +230,7 @@ class Reconstruction {
+@@ -229,7 +229,7 @@ class Reconstruction {
void ImportPLY(const std::string& path);
// Export to other data formats.
@@ -40,28 +40,28 @@ index 4118509..3fd7e0b 100755
const std::string& list_path) const;
void ExportPLY(const std::string& path) const;
diff --git a/src/exe/model_converter.cc b/src/exe/model_converter.cc
-index 1328c24..8039c9a 100755
+index 9e14d73..c5bfcbf 100755
--- a/src/exe/model_converter.cc
+++ b/src/exe/model_converter.cc
-@@ -45,7 +45,7 @@ int main(int argc, char** argv) {
- reconstruction.Read(input_path);
-
- if (output_type == "NVM") {
+@@ -43,7 +43,7 @@ int main(int argc, char** argv) {
+ } else if (output_type == "txt") {
+ reconstruction.WriteText(output_path);
+ } else if (output_type == "nvm") {
- reconstruction.ExportNVM(output_path);
+ reconstruction.ExportNVM(output_path,*options.image_path);
- } else if (output_type == "Bundler") {
+ } else if (output_type == "bundler") {
reconstruction.ExportBundler(output_path + ".bundle.out",
output_path + ".list.txt");
diff --git a/src/ui/main_window.cc b/src/ui/main_window.cc
-index ade5d4e..2b0f5da 100755
+index 09d8020..48c1177 100755
--- a/src/ui/main_window.cc
+++ b/src/ui/main_window.cc
-@@ -783,7 +783,7 @@ void MainWindow::ExportAs() {
- const Reconstruction& reconstruction =
- reconstruction_manager_.Get(SelectedReconstructionIdx());
- if (filter == "NVM (*.nvm)") {
-- reconstruction.ExportNVM(path);
-+ reconstruction.ExportNVM(path,*options_.image_path);
- } else if (filter == "Bundler (*.out)") {
- reconstruction.ExportBundler(path, path + ".list.txt");
- } else if (filter == "PLY (*.ply)") {
+@@ -855,7 +855,7 @@ void MainWindow::ExportAs() {
+ const Reconstruction& reconstruction =
+ reconstruction_manager_.Get(SelectedReconstructionIdx());
+ if (filter == "NVM (*.nvm)") {
+- reconstruction.ExportNVM(export_path);
++ reconstruction.ExportNVM(export_path,*options_.image_path);
+ } else if (filter == "Bundler (*.out)") {
+ reconstruction.ExportBundler(export_path, export_path + ".list.txt");
+ } else if (filter == "PLY (*.ply)") {