summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-03-16 11:23:12 +0100
committerbartus2021-03-16 11:23:12 +0100
commita4bfd2ff1162a7a1e3192defc237ec79e417a6c5 (patch)
tree58cc0a797c040ada05b21abd4dac0171f11cdd51
parent0573e45938a3ad41a0ac40afa540c7d4072c245b (diff)
downloadaur-a4bfd2ff1162a7a1e3192defc237ec79e417a6c5.tar.gz
Drop nvm-export.patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--nvm-export.patch67
3 files changed, 0 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aadcc9059a0..7deb614c90d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,13 +26,11 @@ pkgbase = colmap-git
depends = qt5-base
optdepends = cuda-toolkit: for cuda sfm/mvs acceleration
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
- source = nvm-export.patch
source = gcc9.patch
source = vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin
sha256sums = SKIP
- sha256sums = 566331937811f643da5e4c2e5decae3927e7df293c0647acf2e4789ff2a43750
sha256sums = 531181351f30cfcb531fc961439152840048ff4fa71a27b1efae46421f1ab686
sha256sums = d37d8f19ee0a49705c4c0b06967a08cedfed5cf86519eada3271497256732bc2
sha256sums = d2055600452a531b5b0a62aa5943e1a07195273dc4eeebcf23d3a924d881d53a
diff --git a/PKGBUILD b/PKGBUILD
index de81fea11c03..95482001a0fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,14 +23,12 @@ if [ "$_BUILD_CUDA" == "ON" ] ; then
optdepends+=('cuda-toolkit: for cuda sfm/mvs acceleration')
fi
source=("${pkgname}::git+https://github.com/colmap/colmap.git${_fragment}"
- "nvm-export.patch"
"gcc9.patch"
"vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin"
"vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin"
"vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin"
)
sha256sums=('SKIP'
- '566331937811f643da5e4c2e5decae3927e7df293c0647acf2e4789ff2a43750'
'531181351f30cfcb531fc961439152840048ff4fa71a27b1efae46421f1ab686'
'd37d8f19ee0a49705c4c0b06967a08cedfed5cf86519eada3271497256732bc2'
'd2055600452a531b5b0a62aa5943e1a07195273dc4eeebcf23d3a924d881d53a'
@@ -40,11 +38,6 @@ pkgver() {
git -C "$pkgname" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- git -C "$pkgname" apply -v "$srcdir"/*.patch
-}
-
-
build() {
# determine whether we can precompile CUDA kernels
_CUDA_PKG=$(pacman -Qsq cuda 2>/dev/null) || true
diff --git a/nvm-export.patch b/nvm-export.patch
deleted file mode 100644
index 55514b96f542..000000000000
--- a/nvm-export.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff --git a/src/base/reconstruction.cc b/src/base/reconstruction.cc
-index c9a65fc..29358b3 100755
---- a/src/base/reconstruction.cc
-+++ b/src/base/reconstruction.cc
-@@ -972,7 +972,7 @@ void Reconstruction::ImportPLY(const std::string& path) {
- }
- }
-
--bool Reconstruction::ExportNVM(const std::string& path) const {
-+bool Reconstruction::ExportNVM(const std::string& path, const std::string& image_path) const {
- std::ofstream file(path, std::ios::trunc);
- CHECK(file.is_open()) << path;
-
-@@ -999,7 +999,13 @@ bool Reconstruction::ExportNVM(const std::string& path) const {
- -1 * camera.Params(SimpleRadialCameraModel::extra_params_idxs[0]);
- const Eigen::Vector3d proj_center = image.ProjectionCenter();
-
-- file << image.Name() << " ";
-+ //fix white space in nvm path acordingly
-+ std::string image_path_nvm = image_path ;
-+ std::transform(image_path_nvm.begin(), image_path_nvm.end(), image_path_nvm.begin(), [](char ch) {
-+ return ch == ' ' ? '"' : ch;
-+ });
-+
-+ file << JoinPaths(image_path_nvm, image.Name()) << " ";
- file << f << " ";
- file << image.Qvec(0) << " ";
- file << image.Qvec(1) << " ";
-diff --git a/src/base/reconstruction.h b/src/base/reconstruction.h
-index 7cb5ffb..c2b1d84 100755
---- a/src/base/reconstruction.h
-+++ b/src/base/reconstruction.h
-@@ -229,7 +229,7 @@ class Reconstruction {
- void ImportPLY(const std::vector<PlyPoint>& ply_points);
-
- // Export to other data formats.
-- bool ExportNVM(const std::string& path) const;
-+ bool ExportNVM(const std::string& path,const std::string& image_path) const;
- bool ExportBundler(const std::string& path,
- const std::string& list_path) const;
- void ExportPLY(const std::string& path) const;
-diff --git a/src/exe/colmap.cc b/src/exe/colmap.cc
-index 0a8476b..07e2954 100755
---- a/src/exe/colmap.cc
-+++ b/src/exe/colmap.cc
-@@ -838,7 +838,7 @@ int RunModelConverter(int argc, char** argv) {
- } else if (output_type == "txt") {
- reconstruction.WriteText(output_path);
- } else if (output_type == "nvm") {
-- reconstruction.ExportNVM(output_path);
-+ reconstruction.ExportNVM(output_path,*options.image_path);
- } else if (output_type == "bundler") {
- reconstruction.ExportBundler(output_path + ".bundle.out",
- output_path + ".list.txt");
-diff --git a/src/ui/main_window.cc b/src/ui/main_window.cc
-index 2811fc4..e01a4bb 100755
---- a/src/ui/main_window.cc
-+++ b/src/ui/main_window.cc
-@@ -807,7 +807,7 @@ void MainWindow::ExportAs() {
- const Reconstruction& reconstruction =
- reconstruction_manager_.Get(SelectedReconstructionIdx());
- if (filter == "NVM (*.nvm)") {
-- reconstruction.ExportNVM(export_path);
-+ reconstruction.ExportNVM(export_path,*options_.image_path);
- } else if (filter == "Bundler (*.out)") {
- reconstruction.ExportBundler(export_path, export_path + ".list.txt");
- } else if (filter == "PLY (*.ply)") {