summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-08-20 08:12:20 +0200
committerbartus2018-08-20 08:13:39 +0200
commitadac057d9564c82bce2a031411918b21e7dffd55 (patch)
tree7b7be36e70b385ddbaee40bc56ce56a73e126cb6
parent30f9d6b0760c372041e273f69ec3c58fbf542f84 (diff)
downloadaur-adac057d9564c82bce2a031411918b21e7dffd55.tar.gz
update vocabulary trees url
add .gitignore to prevent delation of vocab trees
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eb74a70fb72..e4385b905cd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.5.dev.2.r16.g983b558
+ pkgver = 3.5.dev.2.r19.gfadc020
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -26,15 +26,15 @@ pkgbase = colmap-git
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
source = colmap-git.install
- source = vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin
- source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin
- source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin
+ source = vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin
+ source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin
+ source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin
md5sums = SKIP
md5sums = 1542bbbaa7951dbf0b2472354b4b493d
md5sums = ebb1dc43e014a1e720a06422c6248a40
- md5sums = 3521ff3c601596473c6ce5256772f606
- md5sums = e423daecc45d56b749d25eeace9de1c8
- md5sums = 7ec70d4137d9b7ca9f076df34808ccc7
+ md5sums = 65b200a06e15205bda713c8553953c50
+ md5sums = 57e1c8073d9085631911e060c3802bd2
+ md5sums = 1c27e2a01d243f40f15595d93cfd0981
pkgname = colmap-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6fbc468213da
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+vocabulary-tree-1M.bin vocabulary-tree-256K.bin vocabulary-tree-32K.bin vocabulary-tree-64K.bin
diff --git a/PKGBUILD b/PKGBUILD
index 05c116109c4c..d59de0c8b554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.5.dev.2.r16.g983b558
+pkgver=3.5.dev.2.r19.gfadc020
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
@@ -23,16 +23,16 @@ install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"nvm-export.patch"
"${pkgname}.install"
- "vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin"
- "vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin"
- "vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin"
+ "vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin"
+ "vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin"
+ "vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin"
)
md5sums=('SKIP'
'1542bbbaa7951dbf0b2472354b4b493d'
'ebb1dc43e014a1e720a06422c6248a40'
- '3521ff3c601596473c6ce5256772f606'
- 'e423daecc45d56b749d25eeace9de1c8'
- '7ec70d4137d9b7ca9f076df34808ccc7')
+ '65b200a06e15205bda713c8553953c50'
+ '57e1c8073d9085631911e060c3802bd2'
+ '1c27e2a01d243f40f15595d93cfd0981')
pkgver() {
cd "$pkgname"