summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-06-20 23:53:33 +0200
committerbartus2019-06-20 23:53:33 +0200
commitd5f7bed2c9a89250f429f64a3c758c6f51b5e9a3 (patch)
tree1430f88e87500e9e9d8edf7cebc0173cf44ca38a
parent1d9654c7721dbb5b1bdeb8593afed576f5209b87 (diff)
downloadaur-d5f7bed2c9a89250f429f64a3c758c6f51b5e9a3.tar.gz
gcc9 fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--gcc9.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbb7ce1c1dfd..4ce39c960799 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.6.dev.1.r47.gc423ca9
+ pkgver = 3.6.dev.2.r12.g7b0c938
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -25,12 +25,14 @@ pkgbase = colmap-git
optdepends = cuda-toolkit: for cuda sfm/mvs acceleration
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
+ source = gcc9.patch
source = colmap-git.install
source = vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin
md5sums = SKIP
md5sums = 1542bbbaa7951dbf0b2472354b4b493d
+ md5sums = c14369d73fabb219537f6cb424c5edee
md5sums = ebb1dc43e014a1e720a06422c6248a40
md5sums = 65b200a06e15205bda713c8553953c50
md5sums = 57e1c8073d9085631911e060c3802bd2
diff --git a/PKGBUILD b/PKGBUILD
index 83b642d29245..e615ccecaf1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.6.dev.1.r47.gc423ca9
+pkgver=3.6.dev.2.r12.g7b0c938
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
@@ -22,6 +22,7 @@ fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"nvm-export.patch"
+ "gcc9.patch"
"${pkgname}.install"
"vocabulary-tree-32K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words32K.bin"
"vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin"
@@ -29,6 +30,7 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
)
md5sums=('SKIP'
'1542bbbaa7951dbf0b2472354b4b493d'
+ 'c14369d73fabb219537f6cb424c5edee'
'ebb1dc43e014a1e720a06422c6248a40'
'65b200a06e15205bda713c8553953c50'
'57e1c8073d9085631911e060c3802bd2'
@@ -41,7 +43,7 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
- git apply ${srcdir}/nvm-export.patch
+ git apply -v ${srcdir}/*.patch
}
diff --git a/gcc9.patch b/gcc9.patch
new file mode 100644
index 000000000000..5fbccf5120ee
--- /dev/null
+++ b/gcc9.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/VLFeat/kmeans.c b/lib/VLFeat/kmeans.c
+index c250ca8..4887fc4 100755
+--- a/lib/VLFeat/kmeans.c
++++ b/lib/VLFeat/kmeans.c
+@@ -669,7 +669,7 @@ VL_XCAT(_vl_kmeans_quantize_, SFX)
+ #endif
+
+ #ifdef _OPENMP
+-#pragma omp parallel default(none) \
++#pragma omp parallel default(none) firstprivate(vl_infinity_d) \
+ shared(self, distances, assignments, numData, distFn, data) \
+ num_threads(vl_get_max_threads())
+ #endif