summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-08-07 16:55:30 +0200
committerbartus2017-08-07 16:55:30 +0200
commitd86061d31c2405f64f93cc88043c2799b485980e (patch)
tree0f036d48930050c36f73b6d405a6a2947841cd63
parent62cd06c0f6a3694ad30372d07a498941cead1510 (diff)
downloadaur-d86061d31c2405f64f93cc88043c2799b485980e.tar.gz
switch to dev branch for eigen 3.3 compatibility
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05220e889e2e..5ac662d5b752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.1.r34.gb44473e
+ pkgver = 3.1.r84.g3c7fd57
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -12,6 +12,7 @@ pkgbase = colmap-git
makedepends = git
makedepends = cmake
makedepends = eigen
+ makedepends = cuda
depends = gflags
depends = suitesparse
depends = freeglut
@@ -21,7 +22,8 @@ pkgbase = colmap-git
depends = boost-libs
depends = qt5-base
optdepends = cuda: for cuda sfm/mvs acceleration
- source = colmap-git::git+https://github.com/colmap/colmap.git
+ options = !buildflags
+ source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
source = colmap-git.install
source = colmap.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 9516220e2247..bdf998ce3a8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
name=colmap
+fragment=dev
pkgname=${name}-git
-pkgver=3.1.r34.gb44473e
+pkgver=3.1.r84.g3c7fd57
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
@@ -9,15 +10,15 @@ url="https://colmap.github.io/"
license=('GPL')
groups=()
depends=('gflags' 'suitesparse' 'freeglut' 'glew' 'google-glog' 'freeimage' 'boost-libs' 'qt5-base')
-makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen')
+makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen' 'cuda')
optdepends=('cuda: for cuda sfm/mvs acceleration')
provides=()
# Fix: -fno-plt flag not supported by cuda host compiler (gcc5)
-options=(!makeflags)
+options=(!buildflags)
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
CXXFLAGS="${CFLAGS}"
install=${pkgname}.install
-source=("${pkgname}::git+https://github.com/colmap/colmap.git"
+source=("${pkgname}::git+https://github.com/colmap/colmap.git#branch=${fragment}"
"nvm-export.patch"
"${pkgname}.install"
"${name}.desktop"