summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRex2020-08-21 11:51:29 +0800
committerRex2020-08-21 11:51:29 +0800
commit102df6abe8e6c9a37782e5be32f8a3b6b920d416 (patch)
tree513f9b96c9ea927cd75a1c5e1b658d02e3f9623d
downloadaur-102df6abe8e6c9a37782e5be32f8a3b6b920d416.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d292a6c2c0bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = color-scripts-launcher-git
+ pkgdesc = Preview color scripts before launching them
+ pkgver = r13.876a869
+ pkgrel = 1
+ url = https://gitlab.com/timescam/color-scripts-launcher
+ arch = any
+ license = WTFPL
+ makedepends = git
+ depends = fzf
+ optdepends = shell-color-scripts: provide colorscripts
+ provides = color
+ source = color-scripts-launcher::git+https://gitlab.com/timescam/color-scripts-launcher.git
+ md5sums = SKIP
+
+pkgname = color-scripts-launcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2b07e441499
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: timescam <rex.ky.ng at gmail dot com>
+
+_pkgname=color-scripts-launcher
+pkgname=$_pkgname-git
+pkgver=r13.876a869
+pkgrel=1
+pkgdesc="Preview color scripts before launching them"
+arch=(any)
+url="https://gitlab.com/timescam/$_pkgname"
+license=('WTFPL')
+depends=('fzf')
+makedepends=('git')
+optdepends=('shell-color-scripts: provide colorscripts')
+
+provides=("color")
+
+source=("$_pkgname::git+https://gitlab.com/timescam/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package () {
+ install -Dm755 "$srcdir/$_pkgname/color" "$pkgdir/usr/bin/color"
+}
+