summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-11-03 15:49:07 +0300
committerorhun2020-11-03 15:49:07 +0300
commitce418405f63b47672e084d44c361f177dddb56db (patch)
tree2800f1576c30bf8e11505567afd893b168130612
downloadaur-ce418405f63b47672e084d44c361f177dddb56db.tar.gz
Initial upload: color_blinder 1.0.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c26ee116531e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = color_blinder
+ pkgdesc = Simulate different kinds of color blindness with a set of images
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/dns2utf8/color_blinder
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = color_blinder-1.0.0.tar.gz::https://gitlab.com/dns2utf8/color_blinder/-/archive/1.0.0/color_blinder-1.0.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = color_blinder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed302f6f5697
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=color_blinder
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Simulate different kinds of color blindness with a set of images"
+arch=('x86_64')
+url="https://gitlab.com/dns2utf8/color_blinder"
+license=('MIT')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}