summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2016-05-01 22:05:04 +0200
committerzoe2016-05-01 22:05:04 +0200
commite1c50bd00026a51ab9a6bdcd4f3cd61de4504206 (patch)
tree94ab7e3b5c87af0d06e2dfa42328151968de7266
downloadaur-e1c50bd00026a51ab9a6bdcd4f3cd61de4504206.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
-rw-r--r--colorcode.desktop10
-rw-r--r--colorcode.install14
-rw-r--r--colorcode.pngbin0 -> 2631 bytes
5 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e4599b48f93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun May 1 20:03:59 UTC 2016
+pkgbase = colorcode
+ pkgdesc = Advanced MasterMind game and solver
+ pkgver = 0.8.5
+ pkgrel = 1
+ url = http://colorcode.laebisch.com/
+ install = colorcode.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ depends = qt5-base
+ source = http://colorcode.laebisch.com/download/ColorCode-0.8.5.tar.gz
+ source = colorcode.desktop
+ source = colorcode.png
+ md5sums = e4ee0dac0c99605af886f3ecd8a55106
+ md5sums = 559b6c3a4eeb81641eaa1a377a2148d6
+ md5sums = 648b63a6de3129b72c752ba893a856a1
+
+pkgname = colorcode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d736330e652b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: zoe <chp321 AT gmail DOT com>
+
+pkgname=colorcode
+_pkgname=ColorCode
+pkgver=0.8.5
+pkgrel=1
+pkgdesc="Advanced MasterMind game and solver"
+arch=('i686' 'x86_64')
+url="http://${pkgname}.laebisch.com/"
+license=('GPL')
+depends=('qt5-base')
+makedepends=('make')
+install=${pkgname}.install
+source=("http://${pkgname}.laebisch.com/download/${_pkgname}-${pkgver}.tar.gz"
+ "${pkgname}.desktop" "${pkgname}.png")
+md5sums=('e4ee0dac0c99605af886f3ecd8a55106'
+ '559b6c3a4eeb81641eaa1a377a2148d6'
+ '648b63a6de3129b72c752ba893a856a1')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ qmake
+ make
+}
+
+package() {
+ install -DTm755 ${srcdir}/${_pkgname}-${pkgver}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -DTm644 ${srcdir}/${pkgname}.png "${pkgdir}/usr/share/icons/hicolor/32x32/apps/${pkgname}.png"
+ install -DTm644 ${srcdir}/${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ }
diff --git a/colorcode.desktop b/colorcode.desktop
new file mode 100644
index 000000000000..49d3b6c500ed
--- /dev/null
+++ b/colorcode.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=colorcode
+Name=ColorCode
+GenericName=advanced MasterMind game and solver
+Comment=
+Icon=/usr/share/icons/hicolor/32x32/apps/colorcode.png
+Terminal=false
+Type=Application
+Categories=Games;
diff --git a/colorcode.install b/colorcode.install
new file mode 100644
index 000000000000..a795fd7deb14
--- /dev/null
+++ b/colorcode.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "Updating mime info..."
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/colorcode.png b/colorcode.png
new file mode 100644
index 000000000000..1ad991f0c0c4
--- /dev/null
+++ b/colorcode.png
Binary files differ