summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Jöhnk2019-10-01 14:52:26 +0200
committerMax Jöhnk2019-10-01 14:52:26 +0200
commit20b2c044dfde6d2db3edcf318d642b2a67c980a7 (patch)
tree53340378eb6e0720507b411d045e0a79935677e3
downloadaur-20b2c044dfde6d2db3edcf318d642b2a67c980a7.tar.gz
Initial setup of package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0437a6489b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = colorex-git
+ pkgdesc = colorex (colorize + regular expression) colorize input lines that match given patterns.
+ pkgver = r8.d06d766
+ pkgrel = 1
+ url = https://github.com/aereal/colorex
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ makedepends = go-pie
+ depends = glibc
+ provides = colorex
+ source = colorex-git::git+https://github.com/aereal/colorex
+ md5sums = SKIP
+
+pkgname = colorex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32a05207cb4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Max Jöhnk <maxjoehnk@gmail.com>
+pkgname=colorex-git
+pkgver=r8.d06d766
+pkgrel=1
+pkgdesc='colorex (colorize + regular expression) colorize input lines that match given patterns.'
+arch=('x86_64')
+url="https://github.com/aereal/colorex"
+license=('unknown')
+groups=()
+depends=('glibc')
+makedepends=('git' 'go-pie')
+provides=('colorex')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+${url}")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-VCS}"
+ go build \
+ -o colorex \
+ -trimpath \
+ -ldflags "-extldflags ${LDFLAGS}"
+}
+
+package() {
+ install -D "$srcdir/${pkgname%-VCS}/colorex" "$pkgdir/usr/bin/colorex"
+}