summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-04-22 18:18:28 +0800
committerChocobo12019-04-22 18:23:34 +0800
commit60d303d1a252c23715e2790044c5e871997cd052 (patch)
tree9ff10e6a2c6a7ba8bc03842285e4d49d4b5d5e03
parenta92f6fe4a72b92728f34716e61ef699c3fe92ac1 (diff)
downloadaur-60d303d1a252c23715e2790044c5e871997cd052.tar.gz
upgpkg: colormake 0.9.20140503-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD58
2 files changed, 34 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b4e13dcc001..c40cebeebceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Wed Feb 22 03:14:16 UTC 2017
pkgbase = colormake
- pkgdesc = A simple wrapper around make to make it's output more readable.
- pkgver = 0.9
- pkgrel = 2
+ pkgdesc = Colorize the output of make
+ pkgver = 0.9.20140503
+ pkgrel = 1
url = http://bre.klaki.net/programs/colormake/
arch = any
license = GPL2
- depends = bash
depends = perl
- conflicts = colormake-git
- source = colormake-0.9.tar.gz::https://github.com/pagekite/Colormake/archive/0.9.tar.gz
- md5sums = 61b3e5a844cfca19675b6f79d70ca3d3
+ depends = bash
+ source = https://github.com/pagekite/Colormake/archive/0.9.20140503.tar.gz
+ sha256sums = a3f9fae9a455ac96be1cce0371b28bda33a9af73b06fa8e4329aa2f693d68d22
pkgname = colormake
diff --git a/PKGBUILD b/PKGBUILD
index 96af27261633..0809308d227e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,45 @@
-# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Former maintainer: John Jenkins <twodopeshaggy@gmail.com>
# Contributor: Mariusz Libera <mariusz.libera@gmail.com>
# Contributor: Juergen Graefe <jg72@gmx.de>
+
pkgname=colormake
-_pkgname=Colormake
-pkgver=0.9
-pkgrel=2
-pkgdesc="A simple wrapper around make to make it's output more readable."
+pkgver=0.9.20140503
+pkgrel=1
+pkgdesc="Colorize the output of make"
arch=('any')
url="http://bre.klaki.net/programs/colormake/"
license=('GPL2')
-conflicts=('colormake-git')
-depends=('bash' 'perl')
-source=($pkgname-$pkgver.tar.gz::https://github.com/pagekite/Colormake/archive/$pkgver.tar.gz)
+depends=('perl' 'bash')
+source=("https://github.com/pagekite/Colormake/archive/$pkgver.tar.gz")
+sha256sums=('a3f9fae9a455ac96be1cce0371b28bda33a9af73b06fa8e4329aa2f693d68d22')
prepare() {
- cd $srcdir/$_pkgname-$pkgver
+ cd "Colormake-$pkgver"
- # adjust scripts to colormake.pl path
- sed -i 's#colormake.pl#/usr/share/colormake/colormake.pl#g' \
- colormake{,-short} clmake*
+ # adjust scripts to colormake.pl path
+ sed -i 's#colormake.pl#/usr/share/colormake/colormake.pl#g' "colormake"
}
-package() {
- cd $srcdir/$_pkgname-$pkgver
+package() {
+ cd "Colormake-$pkgver"
- # executables
- install -dm755 $pkgdir/usr/bin
- install -m755 colormake colormake-short clmake clmake-short $pkgdir/usr/bin
+ # executables
+ install -dm755 "$pkgdir/usr/bin"
+ cp -r {clmake,clmake-short,colormake,colormake-short} "$pkgdir/usr/bin"
- install -Dm755 colormake.pl $pkgdir/usr/share/$pkgname/colormake.pl
+ install -Dm755 "colormake.pl" "$pkgdir/usr/share/colormake/colormake.pl"
- # man page
- install -Dm644 colormake.1 $pkgdir/usr/share/man/man1/colormake.1
+ # man page
+ install -Dm644 "colormake.1" "$pkgdir/usr/share/man/man1/colormake.1"
- # documentation
- install -dm755 $pkgdir/usr/share/doc/$pkgname
- install -m644 \
- AUTHORS \
- BUGS \
- ChangeLog \
- README \
- $pkgdir/usr/share/doc/$pkgname
+ # documentation
+ install -dm755 "$pkgdir/usr/share/doc/colormake"
+ install -m644 \
+ AUTHORS \
+ BUGS \
+ ChangeLog \
+ README \
+ "$pkgdir/usr/share/doc/colormake"
}
-
-md5sums=('61b3e5a844cfca19675b6f79d70ca3d3')