summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-04-22 17:37:58 +0800
committerChocobo12019-04-22 18:14:09 +0800
commit3eb4dbe6da1d7a04157232267a3957fd1dbae6d7 (patch)
treee2b564ba3951e216fbd850cf2a034d9a8869ba68
parent3b0113b8ed33e751aeba4afe3ec6ee32d66d4ed9 (diff)
downloadaur-3eb4dbe6da1d7a04157232267a3957fd1dbae6d7.tar.gz
upgpkg: colormake-git 0.9.20140503.r19.g93dd19b-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD58
2 files changed, 38 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7d84b81bce9..7f929d8e89fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = colormake-git
- pkgdesc = A simple wrapper around make to make it's output more readable
- pkgver = r33.05688ab
+ pkgdesc = Colorize the output of make
+ pkgver = 0.9.20140503.r19.g93dd19b
pkgrel = 1
- url = https://github.com/pagekite/Colormake
- arch = i686
- arch = x86_64
- license = GPL
+ url = http://bre.klaki.net/programs/colormake/
+ arch = any
+ license = GPL2
makedepends = git
depends = perl
+ depends = bash
+ provides = colormake
conflicts = colormake
- source = colormake-git::git+https://github.com/pagekite/Colormake.git
- md5sums = SKIP
+ source = git+https://github.com/pagekite/Colormake.git
+ sha256sums = SKIP
pkgname = colormake-git
diff --git a/PKGBUILD b/PKGBUILD
index a2d5c183f492..c535e4e2a881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,53 @@
-# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Former maintainer: John Jenkins <twodopeshaggy@gmail.com>
# Contributor: Mateusz Loskot <mateusz@loskot.net>
+
pkgname=colormake-git
-_pkgname=colormake
-pkgver=r33.05688ab
+pkgver=0.9.20140503.r19.g93dd19b
pkgrel=1
-pkgdesc="A simple wrapper around make to make it's output more readable"
-arch=('i686' 'x86_64')
-url="https://github.com/pagekite/Colormake"
-license=('GPL')
-conflicts=('colormake')
-depends=('perl')
+pkgdesc="Colorize the output of make"
+arch=('any')
+url="http://bre.klaki.net/programs/colormake/"
+license=('GPL2')
+depends=('perl' 'bash')
makedepends=('git')
-source=("${pkgname}::git+https://github.com/pagekite/Colormake.git")
-md5sums=('SKIP')
+provides=('colormake')
+conflicts=('colormake')
+source=("git+https://github.com/pagekite/Colormake.git")
+sha256sums=('SKIP')
-pkgver() {
- cd "${srcdir}/${pkgname}"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
prepare() {
- cd $srcdir/$pkgname
+ cd "Colormake"
# adjust scripts to colormake.pl path
- sed -i 's#colormake.pl#/usr/share/colormake/colormake.pl#g' colormake
+ sed -i 's#colormake.pl#/usr/share/colormake/colormake.pl#g' "colormake"
+}
+
+pkgver() {
+ cd "Colormake"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- cd $srcdir/$pkgname
+package() {
+ cd "Colormake"
# executables
- install -dm755 $pkgdir/usr/bin
- install -m755 colormake colormake-short clmake clmake-short $pkgdir/usr/bin
+ install -dm755 "$pkgdir/usr/bin"
+ cp -r {clmake,clmake-short,colormake,colormake-short} "$pkgdir/usr/bin"
- install -Dm755 colormake.pl $pkgdir/usr/share/$_pkgname/colormake.pl
+ install -Dm755 "colormake.pl" "$pkgdir/usr/share/colormake/colormake.pl"
# man page
- install -Dm644 colormake.1 $pkgdir/usr/share/man/man1/colormake.1
+ install -Dm644 "colormake.1" "$pkgdir/usr/share/man/man1/colormake.1"
# documentation
- install -dm755 $pkgdir/usr/share/doc/$_pkgname
+ install -dm755 "$pkgdir/usr/share/doc/colormake"
install -m644 \
AUTHORS \
BUGS \
ChangeLog \
README.md \
- $pkgdir/usr/share/doc/$_pkgname
+ "$pkgdir/usr/share/doc/colormake"
}
-
-
-
-# vim:set ts=2 sw=2 et: