summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2020-10-20 02:59:12 +0200
committerredtide2020-10-20 02:59:12 +0200
commit52dfc474f5a86d622cbf524e591b08b92a8c4dcb (patch)
tree3397c3bba32dd5ff19a5422035b14da79af6723d
downloadaur-52dfc474f5a86d622cbf524e591b08b92a8c4dcb.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26f49b67f11d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = colorpick-git
+ pkgdesc = Color picker and contrast checker
+ pkgver = r54.16e386d
+ pkgrel = 1
+ url = https://github.com/agateau/colorpick
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = qt5-base
+ depends = kguiaddons
+ depends = kwidgetsaddons
+ provides = colorpick
+ conflicts = colorpick
+ source = colorpick-git::git+https://github.com/agateau/colorpick.git
+ sha256sums = SKIP
+
+pkgname = colorpick-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b7bed336a121
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar*
+colorpick*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0af1fa916ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: redtide <redtid3@gmail.com>
+
+_pkgname="colorpick"
+pkgname="${_pkgname}-git"
+pkgver=r54.16e386d
+pkgrel=1
+pkgdesc="Color picker and contrast checker"
+url="https://github.com/agateau/${_pkgname}"
+arch=('x86_64')
+license=('BSD')
+depends=('qt5-base' 'kguiaddons' 'kwidgetsaddons')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${pkgname}"::"git+https://github.com/agateau/${_pkgname}.git")
+sha256sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" "${srcdir}/${pkgname}"
+ cmake --build . --target all
+}
+package() {
+ DESTDIR="${pkgdir}" cmake --build "${srcdir}/build" --target install
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}