summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacktea2020-08-20 23:31:26 +0800
committerblacktea2020-08-20 23:31:26 +0800
commit8a7128d57214c259adc571b5e6dae16924c84891 (patch)
tree55ae3ec3796eec273b264c8056d67a5df1d6729a
downloadaur-colorthis-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29fc9da69871
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = colorthis-git
+ pkgdesc = Make your pipe and logfile colorful
+ pkgver = r10.a3f47ea
+ pkgrel = 1
+ url = https://github.com/Sasasu/ColorThis
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ provides = colorthis
+ conflicts = colorthis
+ source = colorthis-git::git+https://github.com/Sasasu/ColorThis.git
+ md5sums = SKIP
+
+pkgname = colorthis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..047b50a62e43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: blacktea <blackteahamburger@outlook.com>
+
+pkgname='colorthis-git'
+pkgver=r10.a3f47ea
+pkgrel=1
+pkgdesc="Make your pipe and logfile colorful"
+arch=('x86_64')
+url='https://github.com/Sasasu/ColorThis'
+license=('MIT')
+makedepends=('cmake' 'git')
+provides=('colorthis')
+conflicts=('colorthis')
+source=('colorthis-git::git+https://github.com/Sasasu/ColorThis.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}