summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-06-08 12:06:05 +0200
committerFadeMind2015-06-08 12:06:05 +0200
commit8f0e1fe125f2c986938e5844c05031282137e72f (patch)
treee338d55a63976afde5630b38944906bfe42beb8e
downloadaur-8f0e1fe125f2c986938e5844c05031282137e72f.tar.gz
1.5.1.rpf2.b19-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26103b15deb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = colorui-themes
+ pkgdesc = Package contains 3 version of gtk3,gtk2,metacity,unity,xfwm4 and openbox theme.
+ pkgver = 1.5.1.rpf2.b19
+ pkgrel = 1
+ url = https://github.com/UserContributer/Color-UI-theme-project
+ arch = any
+ license = GPL3
+ depends = gnome-themes-standard
+ depends = gtk-engine-murrine
+ depends = gdk-pixbuf2
+ source = colorui-themes-1.5.1.rpf2.b19.tar.gz::https://github.com/UserContributer/Color-UI-theme-project/archive/c6cf24f4d3618298c6a22cb4b5ccbab93b610adb.tar.gz
+ sha256sums = ce969373b9c94170eeda90f7ceafd1d349a99892120e04e3e516a7b253f75343
+
+pkgname = colorui-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..093cc9a640b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+
+_pkgname=Color-UI-theme-project
+_gitcommit=c6cf24f4d3618298c6a22cb4b5ccbab93b610adb
+pkgname=colorui-themes
+pkgver=1.5.1.rpf2.b19
+pkgrel=1
+pkgdesc="Package contains 3 version of gtk3,gtk2,metacity,unity,xfwm4 and openbox theme."
+arch=('any')
+url="https://github.com/UserContributer/${_pkgname}"
+license=('GPL3')
+depends=('gnome-themes-standard' 'gtk-engine-murrine' 'gdk-pixbuf2')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${_gitcommit}.tar.gz" )
+sha256sums=('ce969373b9c94170eeda90f7ceafd1d349a99892120e04e3e516a7b253f75343')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/themes
+ install -D -m644 ${srcdir}/${_pkgname}-${_gitcommit}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cp -rf ${srcdir}/${_pkgname}-${_gitcommit}/Color-UI ${pkgdir}/usr/share/themes
+ find ${pkgdir}/usr -type f -exec chmod 644 {} \;
+ find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+}