summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2021-10-29 01:09:00 +0200
committerDušan Simić2021-10-29 01:09:00 +0200
commitf4fc1254b5739e0c68c47a7fe8098897e9566f2e (patch)
tree499c2cfb62726cb5a9caef3f7cb93d7b5d401172
downloadaur-f4fc1254b5739e0c68c47a7fe8098897e9566f2e.tar.gz
Add all files
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8a60e39a8e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = colorway
+ pkgdesc = Generate color pairings
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/lainsce/colorway
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = vala
+ depends = libadwaita
+ depends = json-glib
+ depends = libgee
+ source = colorway::git+https://github.com/lainsce/colorway.git#commit=87bcc4206ee333cc23d818b0f773ebb92dc6ec58
+ md5sums = SKIP
+
+pkgname = colorway
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcb418ba8439
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+
+pkgname=colorway
+_commit=87bcc4206ee333cc23d818b0f773ebb92dc6ec58
+pkgver=1.0.5
+pkgrel=1
+pkgdesc='Generate color pairings'
+arch=(x86_64)
+url=https://github.com/lainsce/colorway
+license=(GPL3)
+depends=(libadwaita json-glib libgee)
+makedepends=(meson vala)
+#checkdepends=(appstream-glib)
+source=("$pkgname::git+$url.git#commit=$_commit")
+md5sums=(SKIP)
+
+build() {
+ arch-meson "$pkgname" build
+ meson compile -C build
+}
+
+check() {
+ :
+ # TODO: Add once desktop file is fixed
+ #meson test -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}