summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrx862021-03-31 16:35:52 +0800
committerbrx862021-03-31 16:35:52 +0800
commit41b2a21b71ec6aa29cfd6884ec53c0950b6c3ccb (patch)
treef2ed68668f6c7a069d37149c496e26a1eac8b082
downloadaur-41b2a21b71ec6aa29cfd6884ec53c0950b6c3ccb.tar.gz
Music
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0c01f8a6bec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = com.caustic3.deepin
+ pkgdesc = A Music Creation Tool, Caustic3 on Deepin Wine5
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = https://singlecellsoftware.com/caustic
+ arch = x86_64
+ license = custom
+ depends = deepin-wine5
+ depends = deepin-wine5-helper
+ provides = caustic3=3.2.1
+ source = https://aya1.xyz/https://github.com/Brx86/yun/releases/download/2/caustic3.tar.gz
+ md5sums = c46c0eef7e614b127dfffeebf1801bb9
+
+pkgname = com.caustic3.deepin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5edec3446ad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sakura1943 <1436700265@qq.com>
+pkgname=com.caustic3.deepin
+pkgver=3.2.1
+pkgrel=1
+pkgdesc="A Music Creation Tool, Caustic3 on Deepin Wine5"
+arch=(x86_64)
+url="https://singlecellsoftware.com/caustic"
+license=('custom')
+depends=('deepin-wine5' 'deepin-wine5-helper')
+provides=(caustic3=$pkgver)
+source=("https://aya1.xyz/https://github.com/Brx86/yun/releases/download/2/caustic3.tar.gz")
+noextract=()
+md5sums=("c46c0eef7e614b127dfffeebf1801bb9")
+
+prepare() {
+ mkdir "$pkgname-$pkgver"
+ cp -r opt "$pkgname-$pkgver"/opt
+ cp -r usr "$pkgname-$pkgver"/usr
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+#}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cp -r opt ${pkgdir}
+ cp -r usr ${pkgdir}
+}