summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-06-12 23:01:26 +0800
committerYour Name2021-06-12 23:01:26 +0800
commit67115e6faff6c0a74e39e7eb44ce653240bbac0f (patch)
tree4d54751c2c0dde1783de877abc33ae6157226dc0
downloadaur-67115e6faff6c0a74e39e7eb44ce653240bbac0f.tar.gz
Pack com.jiakaobaodian.deepin
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD37
-rw-r--r--wineapps.install10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e4ea75661cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = com.jiakaobaodian.deepin
+ pkgdesc = Jia Kao Bao Dian (驾考宝典) Client on Deepin Wine
+ pkgver = 8.2.5
+ pkgrel = 1
+ url = https://www.jiakaobaodian.com/
+ install = wineapps.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine6-stable>=6.0.0.9
+ depends = deepin-wine-helper>=5.1.23
+ depends = p7zip
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.jiakaobaodian.deepin/com.jiakaobaodian.deepin_8.2.5deepin1_i386.deb
+ sha512sums = 236282cd681d64d177eb12a0120543fcc1c335eef2677f1025a2715fa088c6fade8c2e2c0e7682e4bb1f08b4567dd6742a9a72158450a2fac89b26bbf9c50e4a
+
+pkgname = com.jiakaobaodian.deepin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..664ea9189297
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributer: Sam L. Yes <samlukeyes123@gmail.com>
+pkgname=com.jiakaobaodian.deepin
+pkgver=8.2.5
+pkgrel=1
+epoch=
+pkgdesc="Jia Kao Bao Dian (驾考宝典) Client on Deepin Wine"
+arch=('i686' 'x86_64')
+url="https://www.jiakaobaodian.com/"
+license=('unknown')
+groups=()
+depends=('deepin-wine6-stable>=6.0.0.9' 'deepin-wine-helper>=5.1.23' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+replaces=()
+backup=()
+options=()
+install=wineapps.install
+changelog=
+source=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/${pkgname}/${pkgname}_${pkgver}deepin${pkgrel}_i386.deb")
+sha512sums=('236282cd681d64d177eb12a0120543fcc1c335eef2677f1025a2715fa088c6fade8c2e2c0e7682e4bb1f08b4567dd6742a9a72158450a2fac89b26bbf9c50e4a')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries
+ cd opt/apps/${pkgname}/files
+ sed -i "/extract_archive \"/d" run.sh
+ sed -i "s|\$HOME/.deepinwine/deepin-wine-helper|/opt/deepinwine/tools|" run.sh
+ sed -i "s|\$HOME/.deepinwine|/usr/lib|" run.sh
+ rm wine_archive.* helper_archive.*
+}
diff --git a/wineapps.install b/wineapps.install
new file mode 100644
index 000000000000..2790d80b63a9
--- /dev/null
+++ b/wineapps.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ echo
+ echo "Remove ~/.deepinwine/Deepin-JiaKaoBaoDian to generate a new bottle."
+ echo
+}
+
+post_remove() {
+ echo "Deleting existing JiaKaoBaoDian bottles..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-JiaKaoBaoDian/ \;
+} \ No newline at end of file